Play Game (HDU 4597)(dp, 记忆化搜索)

 题目:

Play Game - HDU 4597 - Virtual Judge

Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?

Input

The first line contains an integer T (T≤100), indicating the number of cases.
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer ai (1≤ai≤10000). The third line contains N integer bi (1≤bi≤10000).

Output

For each case, output an integer, indicating the most score Alice can get.

Sample Input

2 
 
1 
23 
53 
 
3 
10 100 20 
2 4 3 

Sample Output

53 
105 

题意:给两堆数量为n的卡牌,两个人可以从其中一堆中的头尾取一个一张价值为a[i]的卡牌。问先行动的人取到的最大值。

解题思路:这题数量少可以开个四维数组,前两维记录第一堆卡牌的一头一尾,即当前所剩下的区间,三四维类似。当我们选择时,那么下一次那个人选择也是最优的,那么彼此都是从中选择一个,使下一个人的得分最小。

代码:

#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

const int N = 50;
int a[N], b[N];
int dp[N][N][N][N];

int dfs(int L1, int R1, int L2, int R2, int sum) {
	if (dp[L1][R1][L2][R2]) return dp[L1][R1][L2][R2];

	int& v = dp[L1][R1][L2][R2];
	if (L1 <= R1) {
		int tmp = min(dfs(L1 + 1, R1, L2, R2, sum - a[L1]), dfs(L1, R1 - 1, L2, R2, sum - a[R1]));
		v = max(v, sum - tmp);
	}

	if (L2 <= R2) {
		int tmp = min(dfs(L1, R1, L2 + 1, R2, sum - b[L2]), dfs(L1, R1, L2, R2 - 1, sum - b[R2]));
		v = max(v, sum - tmp);
	}
	return dp[L1][R1][L2][R2];
}

void solve() {
	int n;
	scanf("%d", &n);

	int sum = 0;
	for (int i = 1; i <= n; i++) scanf("%d", &a[i]), sum += a[i];
	for (int i = 1; i <= n; i++) scanf("%d", &b[i]), sum += b[i];
	memset(dp, 0, sizeof dp);
	dfs(1, n, 1, n, sum);
	printf("%d\n", dp[1][n][1][n]);
}

int main() {
	int t;
	cin >> t;
	while (t--) solve();
	return 0;
}

总结:当时做这题的时候想过开思维空间,可是不懂得用记忆化搜索,导致无法处理某些影响,甚至做题时都想取了状态压缩dp,但那个只能找到所有的最大值,然后想去了博弈,但也猜到影响太大了。dfs还得补一下,递归了解不太透彻。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值