【10分】G. 判断矩形是否重叠(复合类+友元)

题目描述
用CPoint表示点,用两个CPoint对象表示矩形类CRect的对角线两点。分别实现CPoint类和CRect类,并在主函数用输入的坐标定义4个CPoint类对象,每2个CPoint对象再构造1个CRect对象,然后写个友元函数,判断2个矩形是否重叠。

输入
判断次数

矩形1的对角线顶点坐标x1, y1, x2, y2

矩形2的对角线顶点坐标x1, y1, x2, y2

输出
是否重叠

输入样例1

3
1 5 2 9
1 3 2 4
5 6 7 8
5 7 7 7
2 5 1 0
9 4 2 9

输出样例1

not overlapped
overlapped
overlapped

代码

#include <iostream>
using namespace std;

class CPoint
{
private:
    int x, y;

public:
    CPoint(int xx, int yy) {x = xx; y = yy;}
    int getX() {return x;}
    int getY() {return y;}
};

class CRect
{
private:
    CPoint p1, p2;

public:
    CRect(int a1, int a2, int b1, int b2) :p1(a1, a2), p2(b1, b2) {}
    friend bool check(CRect &a, CRect &b);
};

bool check(CRect &a, CRect &b)
{
    if(max(a.p1.getX(), a.p2.getX()) < min(b.p1.getX(),b.p2.getX()) || max(a.p1.getY(),a.p2.getY()) < min(b.p1.getY(),b.p2.getY())
    || min(a.p1.getX(), a.p2.getX()) > max(b.p1.getX(),b.p2.getX()) || min(a.p1.getY(), a.p2.getY()) > max(b.p1.getY(), b.p2.getY()))
    {
        return true;
    }
    else return false;
}

int main( )
{ 
    int t;
    cin >> t;
    while(t --)
    {
        int a1, a2, b1, b2;
        int c1, c2, d1, d2;
        cin >> a1 >> a2 >> b1 >> b2;
        cin >> c1 >> c2 >> d1 >> d2;
        CRect r1(a1, a2, b1, b2), r2(c1, c2, d1, d2);
        
        if(check(r1,r2)) cout << "not overlapped" << endl;
        else cout << "overlapped" << endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叫我胡萝北

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值