G - Box

1587 Box Ivan works at a factory that produces heavy machinery. He has a simple job — he knocks up wooden boxes of different sizes to pack machinery for delivery to the customers. Each box is a rectangular parallelepiped. Ivan uses six rectangular wooden pallets to make a box. Each pallet is used for one side of the box. Joe delivers pallets for Ivan. Joe is not very smart and often makes mistakes — he brings Ivan pallets that do not fit together to make a box. But Joe does not trust Ivan. It always takes a lot of time to explain Joe that he has made a mistake. Fortunately, Joe adores everything related to computers and sincerely believes that computers never make mistakes. Ivan has decided to use this for his own advantage. Ivan asks you to write a program that given sizes of six rectangular pallets tells whether it is possible to make a box out of them. Input Input file contains several test cases. Each of them consists of six lines. Each line describes one pallet and contains two integer numbers w and h (1 ≤ w, h ≤ 10 000) — width and height of the pallet in millimeters respectively. Output For each test case, print one output line. Write a single word ‘POSSIBLE’ to the output file if it is possible to make a box using six given pallets for its sides. Write a single word ‘IMPOSSIBLE’ if it is not possible to do so. Sample Input 1345 2584 2584 683 2584 1345 683 1345 683 1345 2584 683 1234 4567 1234 4567 4567 4321 4322 4567 4321 1234 4321 1234 Sample Output POSSIBLE IMPOSSIBLE

#include<iostream>
using namespace std;
#include<string>
#include<vector>
#include<algorithm>
class Pallet
{
public:
    int w,h;
};
class comparePallet
{
public:
    bool operator()(const Pallet&p1,const Pallet&p2)
    {
        if(p1.h==p2.h)return p1.w<p2.w;
        return p1.h<p2.h;
    }
};
int main()
{
    int a,b,flag;
    Pallet p1;
    vector<Pallet> p;
    while((cin>>a>>b)){
        p1.w=max(a,b);
        p1.h=min(a,b);
        p.push_back(p1);
        for(int i=1;i<6;i++){
            cin>>a>>b;
            p1.w=max(a,b);
            p1.h=min(a,b);
            p.push_back(p1);
        }
        sort(p.begin(),p.end(),comparePallet());//从小到大排序
        flag=1;
        for(vector<Pallet>::iterator it=p.begin();it!=p.end();it+=2){//排序后每两对要相等
            if(it->h!=(it+1)->h||it->w!=(it+1)->w){
                flag=0;
                break;
            }
        }
        if(flag){
            vector<Pallet>::iterator it=p.begin();
            if(it->h!=(it+2)->h||it->w!=(it+4)->h||(it+2)->w!=(it+4)->w){//排序后对应相邻边要想等
                flag=0;
            }    
        }
        if(flag)cout<<"POSSIBLE"<<endl;
        else cout<<"IMPOSSIBLE"<<endl;
        p.clear();
    }
    system("pause");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值