Wall(凸包)

C - Wall
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall. 
Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements. 



The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet. 
 

Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle. 

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices. 
 

Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates. 

This problem contains multiple test cases! 

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks. 

The output format consists of N output blocks. There is a blank line between output blocks. 
 

Sample Input

     
     
1 9 100 200 400 300 400 300 300 400 300 400 400 500 400 500 200 350 200 200 200
 

Sample Output

     
     
1628

#include<iostream>
#include<vector>
#include<cmath>
#include<algorithm>
#include<cstdio>
using namespace std;
#define esp 1e-6
#define PI acos(-1)
int Sign(double x){//判断x大于0,小于0,还是等于0 
	return fabs(x)<esp?0:x>0?1:-1;
}
struct Point{ //存点 
	double x,y;
	Point(){
	}
	Point(double xx,double yy):x(xx),y(yy) { }

	Point operator-(const Point & p) const {
		return Point(x-p.x,y-p.y);
	}

	bool operator <(const Point & p) const {
		if( y < p.y)
			return true;
		else if( y > p.y)
			return false;
		else
			return x < p.x;
	}
};

typedef Point Vector;
double Cross(const Vector & v1, const Vector & v2){//叉积
	return v1.x * v2.y - v2.x * v1.y;
}
double Distance(const Point & p1,const Point & p2){//求距离 
	return sqrt( (p1.x - p2.x)*(p1.x - p2.x) + (p1.y-p2.y)*(p1.y-p2.y));
}

struct Comp { //用来定义极角排序规则的函数对象
	Point p0; //以p0为原点进行极角排序,极角相同的,离p0近算小
	Comp(const Point & p):p0(p.x,p.y) { }
	bool operator ()(const Point & p1,const Point & p2) const {
		int s = Sign( Cross(p1-p0,p2-p0));
		if( s > 0)
			return true;
		else if( s < 0)
			return false;
		else {
			if( Distance(p0,p1)<Distance(p0,p2))
				return true;
			else
				return false;
		}
	}
};

int Graham(vector<Point> & points,vector<Point> & stack) {//求凸包 
	//points是点集合
	if( points.size() < 3)
		return 0; //返回凸包顶点数
	stack.clear();
	//先按坐标排序,最左下的放到points[0]
	sort(points.begin(),points.end());
	//以points[0] 为原点进行极角排序
	sort(points.begin()+1,points.end(),Comp(points[0]));
	stack.push_back(points[0]);
	stack.push_back(points[1]);
	stack.push_back(points[2]);
	for(int i = 3; i< points.size(); ++i) {
		while(true) {
			Point p2 =* (stack.end()-1);
			Point p1 = *(stack.end()-2);
			if( Sign(Cross(p2-p1,points[i]-p2) <= 0))
				//p2->points[i]没有向左转,就让p2出栈
				stack.pop_back();
			else
				break;
		}
		stack.push_back(points[i]);
	}
	return stack.size();
}
int main(){
    double l,n1;
    int n,t,N,L;
    Point p;
    vector<Point> points;
	vector<Point> stack;
	while(~scanf("%d",&t))
	{
	for(int d=1;d<=t;d++)
	{
   
       scanf("%d%d",&n,&L);
    	double res=0;
    	points.clear();
    	stack.clear();
    	for(int i=0;i<n;i++){
    		scanf("%lf %lf",&n1,&l);
    		p.x=n1,p.y=l;
        	points.push_back(p);
		}
		  int size = Graham(points,stack);
		    for(int i=0;i<size-1;i++)
			res+=Distance(stack[i],stack[i+1]);
			res+=Distance(stack[0],stack[size-1]);
            res+=2*PI*L;
	     printf("%d\n",(int)(res+0.5));//四舍五入绝妙方法
		 if(d!=t)
		 printf("\n");     
}
}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值