Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3177 Accepted Submission(s): 1142 Problem Description 传说世上有一支丘比特的箭,凡是被这支箭射到的人,就会深深的爱上射箭的人。
Input 本题目包含多组测试,请处理到文件结束。
Output 对于每枝箭,如果Lele射中了靶子,就在一行里面输出"Yes",否则输出"No"。
Sample Input 4 10 10 20 10 20 5 10 5 2 15 8 25 8
Sample Output Yes No
Author linle
Source
Recommend lcy |
中文题目,
代码:
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
const double eps=1e-10;
const int maxn=1000+10;
int dcmp(double x)
{
if(fabs(x)<eps) return 0;
return x<0?-1:1;
}
struct Point
{
double x,y;
Point(){}
Point(double x,double y):x(x),y(y){}
};
typedef Point Vector;
Vector operator-(Point A,Point B)
{
return Vector(A.x-B.x,A.y-B.y);
}
double Dot(Vector A,Vector B)
{
return A.x*B.x+A.y*B.y;
}
double Cross(Vector A,Vector B)
{
return A.x*B.y-A.y*B.x;
}
bool InSegment(Point P,Point A,Point B)
{
return dcmp( Cross(A-B,P-B) )==0 && dcmp( Dot(A-P,B-P) )<=0;
}
bool PointInPolygon(Point p,Point*poly,int n)
{
int wn=0;
for(int i=0;i<n;++i)
{
if(InSegment(p,poly[i],poly[(i+1)%n])) return true;
int k=dcmp( Cross(poly[(i+1)%n]-poly[i], p-poly[i] ) );
int d1=dcmp( poly[i].y-p.y );
int d2=dcmp( poly[(i+1)%n].y-p.y );
if(k>0 && d1<=0 && d2>0) wn++;
if(k<0 && d2<=0 && d1>0) wn--;
}
if(wn!=0) return true;
return false;
}
int main()
{
int n;
while(scanf("%d",&n)==1 && n)
{
Point poly[maxn],p;
for(int i=0;i<n;++i)
scanf("%lf%lf",&poly[i].x,&poly[i].y);
int k;
scanf("%d",&k);
while(k--)
{
scanf("%lf%lf",&p.x,&p.y);
printf("%s\n",PointInPolygon(p,poly,n)?"Yes":"No");
}
}
return 0;
}