PAT1014. Waiting in Line (30)

题目如下:

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry
题意大致是有多个窗口的排队问题,可以用队列来模拟整个排队过程,前面n*m个顾客是直接排到队伍中的,这n*m个顾客的总时间可以直接计算,第n*m+1个顾客开始,就要计算每个队伍的队首耗时,队首耗时短的先离开,则新的顾客加入该队伍,同时更新相关时间。题目要特别注意的细节是 在17:00前排到队而在17:00以后才结束事务的也可以不用输出Sorry,我一开始用部分错误,是因为我把结束时间在17点以后的都输出Sorry。所以用等待时间小于540来做判断是否输出Sorry是正确的方法。代码如下:

#include <iostream>
#include <queue>
#include <iomanip>
#define MAX 540
using namespace std;

struct Customers {
	int processTimes;
	int totalTimes;
};

int N, M, K, Q;
Customers customers[1001];
queue <Customers> windows[21];
int waitTimes[21] = { 0 };
int frontTimes[21];	//队首元素剩余的业务时间

int findLeastTime()	//找到队首时间最短的
{
	int min = 1;
	for (int i = 2;i < N + 1;i++)
	{
		if (frontTimes[i] < frontTimes[min])
		{
			min = i;
		}
	}

	return min;
}

void changeLines(int index,int customerId)	//根据即将出队的顾客修改队列相关参数
{
	for (int i = 1;i < N + 1;i++)
	{
		if (i != index)
		{
			frontTimes[i] -= frontTimes[index];
		}
	}

	windows[index].pop();
	frontTimes[index] = windows[index].front().processTimes;
	windows[index].push(customers[customerId]);
	customers[customerId].totalTimes = waitTimes[index] + customers[customerId].processTimes;
	waitTimes[index] += customers[customerId].processTimes;
}

int main()
{
	int customer,hour,minute;
	cin >> N >> M >> K >> Q;
	for (int i = 1;i < K + 1;i++)
	{
		cin >> customers[i].processTimes;
		if (i <= N)  //前n个没有等待时间
		{
			customers[i].totalTimes = customers[i].processTimes;
			windows[i].push(customers[i]);
			waitTimes[i] += customers[i].processTimes;
			frontTimes[i] = customers[i].processTimes;	//队首的时间
		}
		else if (i <= N * M)	//前n*m个不需要在黄线后等
		{
			int index = i % N;      //计算排在哪个队伍
			if (index == 0)
				index = N;
			customers[i].totalTimes = waitTimes[index] + customers[i].processTimes;	//总时间为每条队伍的排队时间加上处理业务时间
			windows[index].push(customers[i]);						//加入队列
			waitTimes[index] += customers[i].processTimes;			//队伍的总等待时间增加
		}
		else        //第n*m+1个后需要在黄线后等,哪个队首先出来,加入哪一队
		{
			int index = findLeastTime();
			changeLines(index,i);
		}
	}
		
	for (int i = 0; i < Q;i++)
	{
		cin >> customer;
		if (customers[customer].totalTimes - customers[customer].processTimes >= MAX)
			cout << "Sorry" << endl;
		else
		{
			hour = 8 + customers[customer].totalTimes / 60;
			minute = customers[customer].totalTimes % 60;
			cout << setw(2) << setfill('0') << hour;
			cout << ":";
			cout << setw(2) << setfill('0') << minute;
			cout << endl;
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值