1064 Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4

解题思路:题意是需要将一串数字按照完全二叉搜索树的样子排列,然后再输出树的层次遍历。因为是完全二叉树,所以用一个一维数组就能表示一棵树了,因为二叉搜索树的中序遍历是将数字从小到大输出,所以先通过中序遍历,将完全二叉搜索树构造出来,然后将数组输出就行。

#include<iostream>
#include<stdio.h>
#include<vector>
#include<string.h>
#include<algorithm>
using namespace std;
int tree[3000];
vector<int> nums;
int pos = 0;
void buildTree(int root){
    if (tree[root] == -1){
        return;
    }
    buildTree(root * 2 + 1);
    tree[root] = nums[pos];
    pos++;
    buildTree(root * 2 + 2);
}
int main(){
    for (int n; scanf("%d", &n) != EOF;){
        memset(tree, -1, sizeof(tree));
        nums = vector<int>(n);
        for (int i = 0; i < n; i++){
            scanf("%d", &nums[i]);
            tree[i] = 1;
        }
        sort(nums.begin(), nums.end());
        pos = 0;
        buildTree(0);
        printf("%d",tree[0]);
        for (int i = 1; i < n; i++){
            printf(" %d", tree[i]);
        }
        printf("\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值