1sting

11 篇文章 0 订阅
6 篇文章 0 订阅

1sting

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5129    Accepted Submission(s): 1921


Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 

Output
The output contain n lines, each line output the number of result you can get .
 

Sample Input
  
  
3 1 11 11111
 

Sample Output
  
  
1 2 8
大数版的菲波那切数列问题
#include<cstdio>
#include<cstring>
int main(){
    int t; scanf("%d",&t);
    char a[220];
    
    while(t--){
        scanf("%s",a);
        int len;
        len=strlen(a);
        len--;
        int l=0;
        int  b[220][220]={0};
        b[0][0]=1;b[1][0]=2;//设置首相
        for(int i=2;i<220;i++){
            int p=0,q=0;
            for(int j=0;j<220;j++){
                q=b[i-1][j]+b[i-2][j]+p;
                b[i][j]=q%10;
                p=q/10;
            }
        }//计算出所有项的
        for(int i=219;i>=0;i--){
            if(b[len][i]){
                for(;i>=0;i--)
                    printf("%d",b[len][i]);
            }
        }//输出
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值