HDU-5671 Matrix

Matrix
Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1378 Accepted Submission(s): 545

Problem Description
There is a matrix M that has n rows and m columns (1≤n≤1000,1≤m≤1000).Then we perform q(1≤q≤100,000) operations:

1 x y: Swap row x and row y (1≤x,y≤n);

2 x y: Swap column x and column y (1≤x,y≤m);

3 x y: Add y to all elements in row x (1≤x≤n,1≤y≤10,000);

4 x y: Add y to all elements in column x (1≤x≤m,1≤y≤10,000);

Input
There are multiple test cases. The first line of input contains an integer T(1≤T≤20) indicating the number of test cases. For each test case:

The first line contains three integers n, m and q.
The following n lines describe the matrix M.(1≤Mi,j≤10,000) for all (1≤i≤n,1≤j≤m).
The following q lines contains three integers a(1≤a≤4), x and y.

Output
For each test case, output the matrix M after all q operations.

Sample Input
2
3 4 2
1 2 3 4
2 3 4 5
3 4 5 6
1 1 2
3 1 10
2 2 2
1 10
10 1
1 1 2
2 1 2

Sample Output
12 13 14 15
1 2 3 4
3 4 5 6
1 10
10 1

Hint Recommand to use scanf and printf

很有趣的题目考察自己最数组的模拟思想

#include "cstdio"
#include "algorithm"
using namespace std;
const int MAXX=10000+10;
int map[MAXX][MAXX];
int xa[MAXX];
int ya[MAXX];
int xc[MAXX];
int yc[MAXX];
int n,m;
int q;
int main(){
    int T;scanf("%d",&T);
    while(T--){
        scanf("%d %d %d",&n,&m,&q);
        for(int i=1;i<=n;++i)
            for(int j=1;j<=m;j++)
                scanf("%d",&map[i][j]);
        for(int i=1;i<=n;i++) xa[i]=i,xc[i]=0;
        for(int i=1;i<=m;i++) ya[i]=i,yc[i]=0;
        int a,x,y;
        for(int i=1;i<=q;++i){
            scanf("%d %d %d",&a,&x,&y);
            if(a==1){
                swap(xa[x], xa[y]);
            }
            if(a==2)
                swap(ya[x], ya[y]);
            if(a==3)
                xc[xa[x]]+=y;
            if(a==4)
                yc[ya[x]]+=y;
        }
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                if(j>1)
                    printf(" ");
                printf("%d",map[xa[i]][ya[j]]+xc[xa[i]]+yc[ya[j]]);
            }
            printf("\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值