PAT1002. A+B for Polynomials (25)

题目如下:

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

题意就是要实现多项式的相加。那么我首先想到用链表来做,每个结点储存指数,系数以及指向下一个结点的指针,先将第一行数据构造成一条链表,然后再读第二行数据,遇到指数比当前结点大的,则在该结点之前插入新结点;遇到指数和当前结点一样的,那么直接相加;遇到指数比当前结点小的,则指针向后指;如果遇到空,则在后面创建新结点。大致代码如下:

#include <iostream>
#include <iomanip>
using namespace std;

struct Polynomial {
	int exponent;
	double coefficient;
	Polynomial* next;
};

int main()
{
	Polynomial* head = new Polynomial;
	int exponent;
	double coefficient;
	head->next = nullptr;
	Polynomial *p = head;
	int k, k1, k2; //k记录相加后的多项式项数
	cin >> k1;
	k = k1;
	for (int i = 0; i < k1; i++)
	{
		cin >> exponent >> coefficient;
		p->next = new Polynomial;
		p = p->next;
		p->exponent = exponent;
		p->coefficient = coefficient;
		p->next = nullptr;
	}

	cin >> k2;
	p = head;
	for (int i = 0;i < k2;i++)
	{
		cin >> exponent >> coefficient;
		if (p->next == nullptr)
		{
			p->next = new Polynomial;
			p = p->next;
			p->exponent = exponent;
			p->coefficient = coefficient;
			p->next = nullptr;
			k++;
		}
		else
		{
			while (p->next != nullptr && exponent < p->next->exponent )   //当前读的指数小于当前结点且非空,则一直向后。
			{
				p = p->next;
			}

			if (p->next == nullptr)
			{
				p->next = new Polynomial;
				p = p->next;
				p->exponent = exponent;
				p->coefficient = coefficient;
				p->next = nullptr;
				k++;
			}
			else if (exponent > p->next->exponent)	//当前读的指数比链表上当前结点的大,那么需要插在该结点前面。
			{
				Polynomial* temp = p->next;
				p->next = new Polynomial;
				p->next->exponent = exponent;
				p->next->coefficient = coefficient;
				p = p->next;
				p->next = temp;
				k++;
			}
			else if (exponent == p->next->exponent)   //指数相等则指数不变系数相加
			{
				p->next->coefficient += coefficient;
				p = p->next;
			}

		}
	}

	cout << k;
	p = head;
	while (p->next != nullptr)
	{
		p = p->next;
		cout << " " << p->exponent << " ";
		cout << setiosflags(ios::fixed) << setprecision(1) << p->coefficient;  //保留一位小数
	}

	return 0;
}

但是这样运行用只有基本的测试点通过了,后面4个测试点答案错误:


那么我再仔细想了想,发现忽略了当指数相同时,若系数相加为0,则该项需要删掉的情况,经过修改得到了现在的代码:

#include <iostream>
#include <iomanip>
using namespace std;

struct Polynomial {
	int exponent;
	double coefficient;
	Polynomial* next;
};

int main()
{
	Polynomial* head = new Polynomial;
	int exponent;
	double coefficient;
	head->next = nullptr;
	Polynomial *p = head;
	int k, k1, k2; //k记录相加后的多项式项数
	cin >> k1;
	k = k1;
	for (int i = 0; i < k1; i++)
	{
		cin >> exponent >> coefficient;
		p->next = new Polynomial;
		p = p->next;
		p->exponent = exponent;
		p->coefficient = coefficient;
		p->next = nullptr;
	}

	cin >> k2;
	p = head;
	for (int i = 0;i < k2;i++)
	{
		cin >> exponent >> coefficient;
		if (p->next == nullptr)
		{
			p->next = new Polynomial;
			p = p->next;
			p->exponent = exponent;
			p->coefficient = coefficient;
			p->next = nullptr;
			k++;
		}
		else
		{
			while (p->next != nullptr && exponent < p->next->exponent )   //当前读的指数小于当前结点且非空,则一直向后。
			{
				p = p->next;
			}

			if (p->next == nullptr)
			{
				p->next = new Polynomial;
				p = p->next;
				p->exponent = exponent;
				p->coefficient = coefficient;
				p->next = nullptr;
				k++;
			}
			else if (exponent > p->next->exponent)	//当前读的指数比链表上当前结点的大,那么需要插在该结点前面。
			{
				Polynomial* temp = p->next;
				p->next = new Polynomial;
				p->next->exponent = exponent;
				p->next->coefficient = coefficient;
				p = p->next;
				p->next = temp;
				k++;
			}
			else if (exponent == p->next->exponent)   //指数相等则指数不变系数相加
			{
				p->next->coefficient += coefficient;
				if (p->next->coefficient == 0) //如果相加后为0 则要删除该项
				{
					Polynomial* temp = p->next;
					p->next = temp->next;
					delete temp;
					k--;
				}
				else
					p = p->next;
			}

		}
	}

	cout << k;
	p = head;
	while (p->next != nullptr)
	{
		p = p->next;
		cout << " " << p->exponent << " ";
		cout << setiosflags(ios::fixed) << setprecision(1) << p->coefficient;  //保留一位小数
	}

	return 0;
}

经过这样的修改,就通过了所有的测试点。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值