POJ 2356 Find a multiple(组合数学-抽屉原理)

Find a multiple

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

Source


题目大意:
输入N个数,在其中任意取一些数(一个或多个),使它们的和为N的倍数,输出取数的方案(任意一种)。

解题思路:
解题思路比较巧妙。考虑取数连续的情况,sum[i]表示前缀和,sum[i] - sum[j] 就表示第j+1到i个数的和。
性质1:若sum[p]能被N整除,sum[q]也能被N整除,那么sum[q] - sum[p] (假定q > p) 也一定能被N整除。
N个数形成sum[1]到sum[N]共N段前缀和,它们除以N的余数必定在[0, N-1]区间内,而若sum[i] % N == 0则已经符合题意,即选取第1~i个数,形成的和能被N整除。若不存在整除,则余数在[1,N-1]中,可选值只有N-1个,而sum有N个,其中必有两个模N的余数相同,则根据性质1,找到取数方案,取第p+1~q个数。所以本题必定存在取数方案,输出任意一个即可。

参考代码:
#include <iostream>
#include <cstring>
using namespace std;

const int MAXN = 10010;
int a[MAXN], sum[MAXN], pos[MAXN], n, p, q;

void init() {
    sum[0] = 0;
    p = q = 0;
    memset(pos, 0, sizeof(pos));
}

void input() {
    for (int i = 1; i <= n; i++) {
        cin >> a[i];
        sum[i] = sum[i-1] + a[i];
    }
}

void work() {
    for (int i = n; i >= 1; i--) {
        if (sum[i] % n == 0) {
            p = 1;  q = i;
            return;
        }
    }
    for (int i = 1; i <= n; i++) {
        if (pos[sum[i] % n] != 0) {
            if (i - pos[sum[i] % n] > q - p) {
                p = pos[sum[i] % n] + 1;
                q = i;
            }
        } else {
            pos[sum[i] % n] = i;
        }
    }
}

void output() {
    cout << q - p + 1<< endl;
    for (int i = p; i <= q; i++) {
        cout << a[i] << endl;
    }
}

int main() {
    ios::sync_with_stdio(false);
    while (cin >> n) {
        init();
        input();
        work();
        output();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值