hd1016 Prime Ring Problem

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34025    Accepted Submission(s): 15061


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

 

恩,题目大意就是说,由n个圆圈组成的大圆,每个小圆圈里一个数字范围是从1到n,一个数字只能用一次,而且相邻的小圆圈里的数字之和必须是素数。

开始这题不会写,看了别人的才懂然后又自己写的,据说是回溯,不造是不是在递归的基础上若不满足条件是往回走的意思

#include<cstdio>
#include<cstring>
int prm[45]={0};
int rec[25];
int vis[25];
int n;
void dabiao()
{
	prm[0]=prm[1]=1;
	for(int i=2;i<45;++i)
	{
		for(int j=i+i;j<45;j+=i)
		{
			prm[j]=1;
		}
	}
}
void init()
{
	memset(vis,0,sizeof(vis));
	memset(rec,0,sizeof(rec));
	rec[1]=1;
	vis[1]=1;
}
void dfs(int pos)
{
	if(pos==n&&!prm[rec[n]+1])
	{
		printf("1");
		for(int i=2;i<=n;++i)
			printf(" %d",rec[i]);
		printf("\n");
	}
	for(int i=2;i<=n;++i)
	{
		if(!vis[i]&&!prm[i+rec[pos]])
		{
			pos++;
			rec[pos]=i;
			vis[i]=1;
			dfs(pos);
			vis[i]=0;//个人认为回溯的话,应该是指这里
			pos--;
		}
	}
}
int main()
{
	dabiao();
	int cnt=0;
	while(~scanf("%d",&n))
	{
		cnt++;
		init();
		printf("Case %d:\n",cnt);
		dfs(1);
		printf("\n");
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值