poj 3984 迷宫问题

迷宫问题
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11254 Accepted: 6731

Description

定义一个二维数组:
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
嗯,这题和之前做的不一样,之前都是求最小步数,这个要打印出路径,不会。。。
然后见人家讨论区里开了个数组存之前的点的位置,行乘以5再加上列数
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int map[8][8],mark[8][8];
int rec[30];
int dir[4][2]={0,1,0,-1,1,0,-1,0};
struct node 
{
	int x,y;
};
int judge(int x,int y)
{
	if(x<0||x>=5||y<0||y>=5)
		return 0;
	if(mark[x][y]||map[x][y])
		return 0;
	return 1;
}
void print()
{
	int i=1,u=24,a[30];
	a[0]=24;
	i=1;
	while(1)
	{
		a[i]=rec[u];//倒着输出
		if(rec[u]==0)
			break;
		u=rec[u];
		i++;
	}
	for(int j=i;j>=0;j--)
	{
		int y=a[j]%5;//这里求位置
		int x=a[j]/5;
		printf("(%d, %d)\n",x,y);
	}
}
void bfs(int x,int y)
{
	node ss,now,next;	
	queue<node>q;
	ss.x=0;
	ss.y=0;
	mark[x][y]=1;
	q.push(ss);
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		if(now.x==4&&now.y==4)
		{
			print();
			return ;
		}
		for(int i=0;i<4;++i)
		{
			next.x=now.x+dir[i][0];
			next.y=now.y+dir[i][1];
			if(judge(next.x,next.y))
			{
				rec[next.x*5+next.y]=now.x*5+now.y;//这里存位置
				mark[next.x][next.y]=1;
				q.push(next);
			}
		}
	}
}
int main()
{
	for(int i=0;i<5;++i)
	{
		for(int j=0;j<5;++j)
			scanf("%d",&map[i][j]);
	}
	bfs(0,0);
	return 0;
}

根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的索算法,找到从起点到终点的最短路径。可以使用广度优先索或者深度优先索算法来解决这个问题。 下面是一个使用广度优先索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录路径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先索算法,首先读入迷宫地图,然后从起点开始进行索,直到找到终点为止。在索的过程中,使用标记数组记录已经访问过的位置,使用路径数组记录路径。最后,使用栈来输出路径
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值