poj 1258 Agri-Net 【Prim&Kruskal】

Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 45169 Accepted: 18547

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28
最小生成树。啊今年4 5月份看这部分到现在才看懂prim  贴个Prim和kruskal
//Prim就是先任选一点然后找出最小边,然后更新权值继续找继续更新直到所有点都找完
#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 0x3f3f3f3f
using namespace std;
int road[1010][1010];
int n,vis[1010],rec[10010];
void prim()
{
    int mark,fe=0;
    while(1)
    {
        int minw=maxn,mark=0;
        for(int j=1;j<=n;++j)
        {
            if(!vis[j]&&rec[j]<minw)
            {
                minw=rec[j];
                mark=j;
            }
        }
        if(!mark)
            break;
        vis[mark]=1;
        fe+=minw;
        for(int j=1;j<=n;++j)
        {
            if(!vis[j]&&road[mark][j]<rec[j])
            {
                rec[j]=road[mark][j];
            }
        }
    }
    printf("%d\n",fe);
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(vis,0,sizeof(vis));
        memset(rec,0,sizeof(rec));
        for(int i=1;i<=n;++i)
        {
            for(int j=1;j<=n;++j)
            {
                scanf("%d",&road[i][j]);
            }
        }
        for(int i=1;i<=n;++i)
            rec[i]=road[1][i];
        vis[1]=1;
        prim();
    }
    return 0;
}
kruskal 就是利用并查集这个工具加上排序找边完成的
<pre class="html" name="code">#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int pre[110];
struct node
{
    int a,b,f;
};
node road[11000];
int cmp(node a,node b)
{
    return a.f<b.f;
}
int fd(int a)
{
    if(a!=pre[a])
        pre[a]=fd(pre[a]);
    return pre[a];
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int k=0,fe=0;
        for(int i=1;i<=n;++i)
            pre[i]=i;
        for(int i=0;i<n;++i)
        {
            for(int j=0;j<n;++j)
            {
                scanf("%d",&road[k].f);
                road[k].a=i+1;
                road[k].b=j+1;
                k++;
            }
        }
        sort(road,road+k,cmp);
        for(int i=0;i<k;++i)
        {
            int fa=fd(road[i].a);
            int fb=fd(road[i].b);
            if(fa!=fb)
            {
                pre[fa]=fb;
                fe+=road[i].f;
            }
        }
        printf("%d\n",fe);
    }
    return 0;
}




                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值