HDU 3342 Legal or Not【拓扑排序 邻接表实现】

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5904    Accepted Submission(s): 2732


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 


 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 


 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 


 

Sample Input
  
  
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 


 

Sample Output
  
  
YES NO

 

嗯,题目大意就是说,其实就是拓扑排序,找入度为0的点,在把与它相关的边删掉,之后继续找点,然后这题就是说一直找到最后看是否有入度不为0的点若有则输出NO无输出YES

 

 

#include <iostream>
#include<cstdiO>
#include<cstring>
#include<queue>
#define maxn 10010
using namespace std;
int cnt,in[maxn],head[maxn];
queue<int>q;
struct node
{
    int a,b,next;
};
node edge[maxn];
void add(int a,int b)
{
    edge[cnt].a=a;
    edge[cnt].b=b;
    edge[cnt].next=head[a];
    head[a]=cnt;
    cnt++;
}
void top_sort()
{
    int u,v;
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
           v=edge[i].b;
           in[v]--;
           if(in[v]==0)
           {
               in[v]=-1;
               q.push(v);
           }
        }
    }
}
int main()
{
    int x,y,n,m,flag;
    while(scanf("%d%d",&n,&m)&&n)
    {
        cnt=0;
        flag=0;
        memset(in,0,sizeof(in));
        memset(head,-1,sizeof(head));
        while(!q.empty())
            q.pop();
        for(int i=0;i<m;++i)
        {
            scanf("%d%d",&x,&y);
            add(x,y);
            in[y]++;
        }
        for(int i=0;i<n;++i)
        {
            if(in[i]==0)
            {
                in[i]=-1;
                q.push(i);
            }
            top_sort();
        }
        for(int i=0;i<n;++i)
        {
            if(in[i]!=-1)
            {
                flag=1;
                break;
            }
        }
        if(flag)
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值