POJ 3187 Backward Digit Sums 【穷竭搜索 next_permutation函数】

Backward Digit Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5411 Accepted: 3122

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.

恩,题目大意就是说,给一个特定的从1到 n 的序列,按照上面的规则进行运算直到只剩一个数,现在是给你 n 的值和最后剩下的那个值,求的特定序列,若序列有多个,输出字典序最小的


#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,a[20];
int solve()
{
    int b[20],m=n;
    for(int i=1;i<=m;++i)
        b[i]=a[i];
    while(m>1)
    {
        for(int i=1;i<=m;++i)
            b[i]=b[i]+b[i+1];
        m--;
    }
    return b[1];
}
int main()
{
    int sum,flag;
    while(~scanf("%d%d",&n,&sum))
    {
        flag=0;
        for(int i=1;i<=n;++i)
            a[i]=i;
        if(solve()==sum)
            flag=1;
        if(!flag)
        {
            while(next_permutation(a+1,a+n+1))
            {
                if(solve()==sum)
                    break;
            }
        }
        for(int i=1;i<=n;++i)
        {
            if(i==1)
                printf("%d",a[i]);
            else
                printf(" %d",a[i]);
        }
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值