HDOJ 5610 Baby Ming and Weight lifting

16 篇文章 0 订阅

Baby Ming and Weight lifting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 446    Accepted Submission(s): 174


Problem Description
Baby Ming is fond of weight lifting. He has a barbell pole(the weight of which can be ignored) and two different kinds of barbell disks(the weight of which are respectively a and b ), the amount of each one being infinite.

Baby Ming prepare to use this two kinds of barbell disks to make up a new one weighted C (the barbell must be balanced), he want to know how to do it.

 

Input
In the first line contains a single positive integer T , indicating number of test case.

For each test case:

There are three positive integer a,b , and C .

1T1000,0<a,b,C1000,ab
 

Output
For each test case, if the barbell weighted C can’t be made up, print Impossible.

Otherwise, print two numbers to indicating the numbers of a and b barbell disks are needed. (If there are more than one answer, print the answer with minimum a+b )
 

Sample Input
  
  
2 1 2 6 1 4 5
 

Sample Output
  
  
2 2 Impossible
 

有一句话,叫自作自受


#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int main()
{
    int t,a,b,c,aa,bb;
    scanf("%d",&t);
    while(t--)
    {
        aa=bb=0;
        scanf("%d%d%d",&a,&b,&c);
        if(c&1)
        {
            printf("Impossible\n");
            continue;
        }
        if(c==0)
        {
            printf("0 0\n");
            continue;
        }
        int n=c/2;
        int flag=0;
        if(a>b)
        {
            flag=1;
            int tem=a;
            a=b;
            b=tem;
        }
        if(a>n)
            printf("Impossible\n");
        else
        {
            if(b>n)
            {
                if(n%a==0)
                {
                    if(!flag)
                        printf("%d 0\n",(n/a)*2);
                    else
                        printf("0 %d\n",(n/a)*2);
                }
                else
                    printf("Impossible\n");
            }
            else
            {
                if(n%b==0)
                {
                    if(!flag)
                        printf("0 %d\n",(n/b)*2);
                    else
                        printf("%d 0\n",(n/b)*2);
                }
                else
                {
                    int i=n/b;
                    int rec=0;
                    for(;i>=0;--i)
                    {
                        int tem=n-i*b;
                        if(tem>0&&tem%a==0)
                        {
                            rec=1;
                            if(!flag)
                                printf("%d %d\n",(tem/a)*2,i*2);
                            else
                                printf("%d %d\n",i*2,(tem/a)*2);
                            break;
                        }
                    }
                    if(!rec)
                        printf("Impossible\n");
                }
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值