HDU:1950 Bridging signals

Bridging signals

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2197    Accepted Submission(s): 1448

题目链接
Problem Description
'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too
expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without rossing each other, is imminent. Bearing in mind that there may be housands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?

Figure 1. To the left: The two blocks' ports and their signal mapping (4,2,6,3,1,5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged. 

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number pecifies which port on the right side should be connected to the i:th port on the left side.
Two signals cross if and only if the straight lines connecting the two ports of each pair do.
 

Input
On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p<40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping: On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.
 

Output
For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.
 

Sample Input
  
  
4 6 4 2 6 3 1 5 10 2 3 4 5 6 7 8 9 10 1 8 8 7 6 5 4 3 2 1 9 5 8 9 2 3 1 7 4 6
 

Sample Output
  
  
3 9 1 4
题目意思和输入的测试数据难理解,第一行输入一个数N代表几组测试数据,然后输入P代表每一组测试数据有几个数。比如第一组p=6
输入的数据为4 2 6 3 1 5 依次与 1 2 3 4 5 6想对应,即连接起来,但是任何两条线都不能交叉,求最多的路的条数。
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>

using namespace std;

int lis[40005];//存放longest increasing subsequence的数组
int len;
int Binary_Search(int n)  //二分查找,时间复杂度为对数阶
{
    int low,high,mid;
    low = 1;
    high = len;
    while(low<high)
    {
        mid = (low+high)/2;
        if(lis[mid]>=n)
            high = mid;
        else
            low = mid+1;  //只让下届做改变
    }
    return low;
}
int main()
{
    int n,p,a;
    scanf("%d",&n);  //n组测试数据
    while(n--)
    {
        scanf("%d",&p);
        len = 0;
        lis[len]=0;
        while(p--)
        {
            scanf("%d",&a);
            if(a>lis[len])
            {
                len++;
                lis[len]=a;
            }
            else
            {
                int pos = Binary_Search(a);
                lis[pos]=a;
            }
        }
        printf("%d\n",len);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值