Conquer a New Region(并查集+贪心)

并查集:

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3659

Conquer a New Region


Time Limit: 5 Seconds      Memory Limit: 32768 KB


The wheel of the history rolling forward, our king conquered a new region in a distant continent.

There are N towns (numbered from 1 to N) in this region connected by several roads. It's confirmed that there is exact one route between any two towns. Traffic is important while controlled colonies are far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to transport at most C(i, j) goods between town i and town j if there is a road between them. And for a route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and j which is equal to the minimum capacity of the roads on the route.

Our king wants to select a center town to restore his war-resources in which the total traffic capacities from the center to the other N - 1 towns is maximized. Now, you, the best programmer in the kingdom, should help our king to select this center.

Input

There are multiple test cases.

The first line of each case contains an integer N. (1 ≤ N ≤ 200,000)

The next N - 1 lines each contains three integers a, b, c indicating there is a road between town a and town b whose capacity is c. (1 ≤ a, b ≤ N, 1 ≤ c ≤ 100,000)

Output

For each test case, output an integer indicating the total traffic capacity of the chosen center town.

Sample Input

4
1 2 2
2 4 1
2 3 1
4
1 2 1
2 4 1
2 3 1

Sample Output

4
3

题目大意:

就是从一个点开始到其他的所有点,然后价值是路径上的最短边的总和。求这个最大值。

解题思路:

按边排序,从大到小插入,每条边将两个集合连起来,而新加的边是两个集合所有边最小的,那么两个集合中的点交叉的通路最小的边就是新加的,那只要枚举两个集合,a,b是a并入b更优还是b并入a更优就行了。集合内部点已经计算出,相互的只要知道集合中元素的个数就好了。

所以并查集只需要维护一个集合的元素个数,一个集合的总权值

本文来自:

https://blog.csdn.net/u011262722/article/details/10177019

时间有限,代码就不敲了。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define N 200005
#define MOD 1000000007
#define LL long long
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
struct Node
{
    int u,v,w;
    bool operator< (const Node n1) const
    {
        return w>n1.w;
    }
}edge[N];
int cnt[N],pre[N];
LL sum[N];
int find(int a)
{
    return pre[a]=(a==pre[a]?a:find(pre[a]));
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n-1;i++)
        {
            scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
        }
        sort(edge,edge+n-1);
        for(int i=1;i<=n;i++)
        {
            sum[i]=0;
            pre[i]=i;
            cnt[i]=1;
        }
        LL ans=0;
        for(int i=0;i<n-1;i++)
        {
            int ra=find(edge[i].u);
            int rb=find(edge[i].v);
            LL atob=(LL)cnt[ra]*edge[i].w+sum[rb];
            LL btoa=(LL)cnt[rb]*edge[i].w+sum[ra];
            if(atob>btoa)
            {
                pre[ra]=rb;
                cnt[rb]+=cnt[ra];
                sum[rb]=atob;
            }
            else
            {
                pre[rb]=ra;
                cnt[ra]+=cnt[rb];
                sum[ra]=btoa;
            }
            ans=max(ans,max(atob,btoa));
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值