PAT A1069

  • 题目:
    For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.
Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).
Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.
Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

  • 解题思路
    方法一:
    to_array函数 : 将整数转化为数组
    to_int 函数: 将数组转化为整数
#include <cstdio>
#include <algorithm>
using namespace std;
bool cmp(int a, int b){
    return a > b;
}
void to_array1(int n, int num[]){
    for(int i = 0; i< 4; i++){
        num[i] = n %10;
        n /= 10;
    }
}
int to_int(int num[]){
    int sum = 0;
    for(int i = 0; i < 4; i++){
        sum = sum*10 + num[i];
    }
    return sum;
}
int main()
{
    int n, MIN, MAX;
    scanf("%d", &n);
    int num[4];
    while(1){
        to_array1(n, num);
        sort(num, num+4, cmp);
        MAX = to_int(num);
        sort(num, num+4);
        MIN = to_int(num);
        n = MAX - MIN;
        printf("%04d - %04d = %04d\n", MAX, MIN, n);
        if(n == 0 || n == 6174)
            break;
    }
    return 0;
}

方法二: 利用string类型
stoi()方法:将string转化为整数
to_string()方法: 将整数转化为string

#include <iostream>
#include <algorithm>
using namespace std;
bool cmp(char a, char b){
    return a > b;
}
int main()
{
    string s;
    cin >> s;
    s.insert(0, 4-s.length(), '0');
    do{
        string a = s, b = s;
        sort(a.begin(), a.end(), cmp);
        sort(b.begin(), b.end());
        int res = stoi(a) - stoi(b);
        s = to_string(res);
        s.insert(0, 4-s.length(), '0');
        cout << a <<" - " << b <<" = " << s << endl;
    }while(s != "6174" && s != "0000");
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值