PAT A1063

2 篇文章 0 订阅
  • 题目:
    Given two sets of integers, the similarity of the sets is defined to be N​c​​/N​t​​×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and N​t​​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.
    Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10​4​​) and followed by M integers in the range [0,10​9​​]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.
Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.
Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

  • 题目大意
    给定两个集合,求集合的交与集合的并的比

  • 分析
    STL中的set存储不重复的元素并且自动排序,定义一个set数组来存储集合。
    对于任意两个集合,查找第一个集合中的元素是否在第二个集合中出现,若出现,则交集元素加一,不出现,并集元素加一,并且并集元素初始值为第一个set的元素个数

  • 代码实现:

#include <cstdio>
#include <set>
using namespace std;
int main()
{
    int n, c, num, query, temp1;
    scanf("%d", &n);
    set<int> res[n+1];
    for(int i = 1; i <= n; i++){
        scanf("%d", &c);
        for(int j = 0; j < c; j++){
            scanf("%d", &temp1);
            res[i].insert(temp1);                 //将其加入集合
        }
    }
    scanf("%d", &query);
    for(int i = 0; i < query; i++){
        int x1, x2;
        scanf("%d %d", &x1, &x2);
        int sum1 = 0, sum2 = res[x2].size();
        for(auto it = res[x1].begin(); it != res[x1].end(); it++){
            if(res[x2].find(*it) == res[x2].end())
                sum2++;
            else
                sum1++;
        }
        printf("%.1f%\n",((double)sum1 / sum2) * 100 );
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值