POJ-3565-Ants-KM算法

Description

Young naturalist Bill studies ants in school. His ants feed on plant-louses that live on apple trees. Each ant colony needs its own apple tree to feed itself.

Bill has a map with coordinates of n ant colonies and n apple trees. He knows that ants travel from their colony to their feeding places and back using chemically tagged routes. The routes cannot intersect each other or ants will get confused and get to the wrong colony or tree, thus spurring a war between colonies.

Bill would like to connect each ant colony to a single apple tree so that all n routes are non-intersecting straight lines. In this problem such connection is always possible. Your task is to write a program that finds such connection.

On this picture ant colonies are denoted by empty circles and apple trees are denoted by filled circles. One possible connection is denoted by lines.

Input

The first line of the input file contains a single integer number n (1 ≤n ≤ 100) — the number of ant colonies and apple trees. It is followed by n lines describing n ant colonies, followed by n lines describing n apple trees. Each ant colony and apple tree is described by a pair of integer coordinatesx and y (−10 000 ≤ x, y ≤ 10 000) on a Cartesian plane. All ant colonies and apple trees occupy distinct points on a plane. No three points are on the same line.

Output

Write to the output file n lines with one integer number on each line. The number written oni-th line denotes the number (from 1 to n) of the apple tree that is connected to thei-th ant colony.

Sample Input

5
-42 58
44 86
7 28
99 34
-13 -59
-47 -44
86 74
68 -75
-68 60
99 -60

Sample Output

4
2
1
5
3

Source




#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f
double S=1e-6;
double G[105][105],slack[105];
int visx[105],visy[105];
double lx[105],ly[105];
int match[105],ans[105],n;
struct point
{
	double x,y;
}p[205];
double dis(point a,point b)
{return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));}
int dfs(int x)
{
	visx[x]=1;
	for(int y=1;y<=n;y++)
	{
		if(visy[y]) continue;
		double c=lx[x]+ly[y]-G[x][y];
		if(c<S)
		{
			visy[y]=1;
			if(match[y]==-1||dfs(match[y]))
			{
				match[y]=x;
				return 1;
			}
		}
		else if(slack[y]-c>S)
		slack[y]=c;
	}
	return 0;
}
void KM()
{
	memset(match,-1,sizeof(match));
	memset(lx,0,sizeof(lx));
	memset(ly,0,sizeof(ly));
	for(int i=1;i<=n;i++)
	for(int j=1;j<=n;j++)
	if(G[i][j]>lx[i])
	lx[i]=G[i][j];
	for(int x=1;x<=n;x++)
	{
		for(int i=1;i<=n;i++) slack[i]=INF; 
		while(1)
		{
			memset(visx,0,sizeof(visx));
			memset(visy,0,sizeof(visy));
			if(dfs(x))break;
			double d=INF;
			for(int i=1;i<=n;i++)
			if(!visy[i]&&d>slack[i]) 
			d=slack[i];
			for(int i=1;i<=n;i++)
			{
				if(visx[i])lx[i]-=d;
				if(visy[i])ly[i]+=d;
				else slack[i]-=d;	
			}
		}
	}
}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		
		memset(G,0,sizeof(G));
		for(int i=1;i<=2*n;i++)
		scanf("%lf%lf",&p[i].x,&p[i].y);
		for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++)
		G[i][j]-=dis(p[i],p[j+n]);
		KM();
		for(int i=1;i<=n;i++)
		ans[match[i]]=i;
		for(int i=1;i<=n;i++)
		printf("%d\n",ans[i]);
	}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值