http://poj.org/problem?id=3984
定义一个二维数组:
int maze[5][5] = {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
思路:既然求解的是最短路线,bfs即可,同时记录一下路径。
#include<iostream>
#include<cstdio>
#include<stack>
#include<cmath>
#include<cstring>
#include<queue>
#include<set>
#include<algorithm>
#include<iterator>
#define P pair<int,int>
#define INF 0x3f3f3f3f
typedef long long ll;
typedef unsigned long long ull;
using namespace std;
struct node
{
int x,y,step;
P path[30];
};
int d[4][2]={{-1,0},{0,-1},{1,0},{0,1}};
int s[10][10];
int vis[10][10];
void solve()
{
vis[0][0]=1;
queue<node> q;
node a;
a.x=0,a.y=0,a.step=0;
q.push(a);
while(!q.empty())
{
node b=q.front();
node c=q.front();
q.pop();
if(b.x==4&&b.y==4)
{
for(int i=0;i<=b.step;i++)
printf("(%d, %d)\n",b.path[i].first,b.path[i].second);
return ;
}
for(int i=0;i<4;i++)
{
int dx=b.x+d[i][0];
int dy=b.y+d[i][1];
if(dx>=0&&dx<5&&dy>=0&&dy<5&&s[dx][dy]!=1&&!vis[dx][dy])
{
vis[dx][dy]=1;
c.x=dx,c.y=dy,c.step=b.step+1;
P p(dx,dy);
c.path[c.step]=p;
q.push(c);
}
}
}
}
int main()
{
for(int i=0;i<5;i++)
for(int j=0;j<5;j++)
scanf("%d",&s[i][j]);
solve();
return 0;
}