http://acm.hdu.edu.cn/showproblem.php?pid=1213
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5
5 1
2 5
Sample Output
2
4
题目大意:你要在家开个party,互相认识的人可以坐在同一张桌子上,求桌子个数。这里的互相认识我们这样定义,A认识B,B认识C,那么A就是认识C。
思路:很明显的并查集,如果两个人认识,那么我就就把他们各自所在的团队合并到一起。最后统计一下团队的个数。具体的操作就是,刚开始认为每个人占一个桌子,如果两人认识,我们撤走一个人的桌子,让他们坐在一起。如果不知道并查集是什么的话,推荐看一下这位博主的博客。
https://www.cnblogs.com/xzxl/p/7226557.html
#include<iostream>
#include<cstdio>
#include<stack>
#include<cmath>
#include<cstring>
#include<queue>
#include<set>
#include<algorithm>
#include<iterator>
#define INF 0x3f3f3f3f
typedef long long ll;
typedef unsigned long long ull;
using namespace std;
int f[1005];
int flag[1005];
int n;
void init()
{
for(int i=1;i<=n;i++)
{
f[i]=i;
flag[i]=1;
}
}
int father(int x)
{
return f[x]==x?x:f[x]=father(f[x]);
}
void Union(int x,int y)
{
int fx=father(x),fy=father(y);
if(fx==fy)
return ;
else
{
f[fx]=fy;
flag[fx]=0;
}
}
int main()
{
int t;
int m;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
init();
int t1,t2;
for(int i=0;i<m;i++)
{
scanf("%d%d",&t1,&t2);
Union(t1,t2);
}
int cnt=0;
for(int i=1;i<=n;i++)
if(flag[i])
cnt++;
printf("%d\n",cnt);
}
return 0;
}