Description
In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be
.
Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.
Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes
Input
The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.
Output
For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.
Sample Input
3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0
Sample Output
83
100
Hint
To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).
题意
题解:
一定要好好读题 k=n-k!!!
代码
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <algorithm>
using namespace std;
const int N = 1e3+100;
const double eps = 1e-7;
double v[N];
double w[N];
int a[N];
double y[N];
int n,k;
bool cmp(int a,int b){
return y[a]>y[b];
}
bool check(double x){
for (int i = 1; i <= n; ++i){
y[i] = v[i]-x*w[i];
a[i] = i;
}
sort(a+1,a+n+1,cmp);
double sum = 0;
for (int i = 1; i <= k; ++i){
sum +=y[a[i]];
}
return sum>=0;
}
int main(){
while (scanf("%d%d",&n,&k),n!=0||k!=0){
double r = 0;
k=n-k;
for (int i = 1; i <= n; ++i){
scanf("%lf",&v[i]);
}
for (int i = 1; i <= n; ++i){
scanf("%lf",&w[i]);
r = max(r,v[i]/w[i]);
}
double l = 0,mid;
while (r-l>eps){
mid = (l+r)/2;
if (check(mid)) l = mid;
else r = mid;
}
printf("%.0f\n",l*100);
}
return 0;
}