HDU 2199 Can you solve this equation?(二分)

原题链接

Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

题目大意

给定Y,解出X。

解题思路

由于函数是单调的,所以只需二分找出答案即可。

AC代码

#include<bits/stdc++.h>
#define ll long long
#define rep(i,a,b) for (int i=(a),_ed=(b);i<=_ed;i++)
#define fil(a,b) memset((a),(b),sizeof(a))
#define cl(a) fil(a,0)
#define PI 3.1415927
#define inf 0x3f3f3f3f
using namespace std;
int main()
{
    int t;
    double n;
    double from,to,mid;
    cin>>t;
    while(t--)
    {
        from=0;
        to=100;
        cin>>n;
        if(!(n>=6&&n<=807020306)) cout<<"No solution!"<<endl;
        else if(n==6) cout<<"0.0000"<<endl;
        else if(n==807020306) cout<<"100.0000"<<endl;
        else
        {
            while(to-from>1e-6)
            {
                mid=from+(to-from)/2;
                if(8*pow(mid,4)+7*pow(mid,3)+2*pow(mid,2)+3*mid+6>n) to=mid;
                else from=mid;
            }
            printf("%.4lf\n",to);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值