1005. Spell It Right (20)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five

提交代


————————————————————


如果res为0的时候,这样vector就会为空,所以在第三个测试点会出现段错误?应该是这个问题。


其他比较简单。

注意输入输出的格式。。。。gets()函数。。。。

http://blog.csdn.net/xkzju2010/article/details/45509781

http://blog.csdn.net/xkzju2010/article/details/45619145


#include <iostream>
#include <string>
#include <cstring>
#include <stdlib.h>
#include <vector>
using namespace std;

/* run this program using the console pauser or add your own getch, system("pause") or input loop */
#define MAX 110

int main(int argc, char** argv) {
	char n[MAX];
	char Num[10][8]={"zero","one","two","three","four","five","six","seven","eight","nine"};
	int i=0,res=0;

	gets(n);
	while(n[i] !='\0')
	{
		res+=(n[i]-'0');
		i++;
	}
	if(res==0)
	{
		printf("zero");
		return 0;
	}
	vector<int> v;
	while(res > 0)
	{
		v.push_back(res%10);
		res/=10;
	}
	for(i=v.size()-1; i>0; i--)
	{
		printf("%s ",Num[v[i]]);
	}
	printf("%s",Num[v[0]]);
	
	return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值