1014. Waiting in Line (30)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waitingarea into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry

提交代

——————————

就是一个排队的东西,用queue来做应该是比较简单的。

但是,我第一思路是很复杂的,涉及到结构体,就是构造一个每个人的结构体,将其等待时间放在people的属性中。

感觉比较复杂,下面是另外一个童靴的。

主要的思路如下。

1,一个queue数组来存储N个队列中的人

2,top来指向当前的人,判断其离开等属性。

3,对于在不在排队,在第二个黄线之外的需要进行判断哪一个empty,找到index,并在这个队中进行pop和push进去。




#include <iostream>
#include <queue>
#include <stdlib.h>
using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */

#define MAX 1010
#define INT_MAX 0x6fffffff


int main(int argc, char** argv) {
	int N,M,K,Q;
	queue<int> q[25];
	int Time[MAX]={0};
	int LeaveTime[MAX]={0};
	int Timebase[MAX]={0};
	cin>>N>>M>>K>>Q;
	for(int i=0; i<K; i++)
	{
		cin>>Time[i];
	}
	int top=0,index=0;
	for(int i=0; top<M*N && top<K; top++)
	{
		q[i].push(top);
		LeaveTime[top]=Timebase[i]+Time[top];
		Timebase[i]=LeaveTime[top];
		i=(i+1)%N;
	}
	for(;top<K; top++)
	{
		int min_wait=INT_MAX;
		bool found=false;
		for(int j=0; j<N; j++)
		{
			int cus=q[j].front();
			if(min_wait>LeaveTime[cus])
			{
				min_wait=LeaveTime[cus];
				index=j;
				found=true;
			}
		}
		q[index].pop();
		q[index].push(top);
		LeaveTime[top]=Timebase[index]+Time[top];
		Timebase[index]=LeaveTime[top];
	}
	for(int i=0; i<Q; i++)
	{
		int asker;
		cin>>asker;
		asker--;
		if(LeaveTime[asker]-Time[asker]>=60*9)
		{
			cout<<"Sorry"<<endl;
		}
		else
		{
			int hr=LeaveTime[asker]/60;
			int sec=LeaveTime[asker]%60;
			printf("%02d:%02d\n",hr+8,sec);
		}
	}
	
	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值