Is Derek lying? - HDU 6045 - 2017多校

140 篇文章 0 订阅
91 篇文章 0 订阅

题目:

Problem Description

  Derek and Alfia are good friends.Derek is Chinese,and Alfia is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of N choice questions and each question is followed by three choices marked “A” “B” and “C”.Each question has only one correct answer and each question is worth 1 point.It means that if your answer for this question is right,you can get 1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell Derek the total score of him and Alfia.Then Alfia will ask Derek the total score of her and he will tell her: “My total score is X,your total score is Y.”But Derek is naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made,you should judge whether Derek is lying.If there exists a set of standard answer satisfy the total score that Derek said,you can consider he is not lying,otherwise he is lying.

Input

  The first line consists of an integer T,represents the number of test cases.

  For each test case,there will be three lines.

  The first line consists of three integers N,X,Y,the meaning is mentioned above.

  The second line consists of N characters,each character is “A” “B” or “C”,which represents the answer of Derek for each question.

  The third line consists of N characters,the same form as the second line,which represents the answer of Alfia for each question.

  Data Range:1≤N≤80000,0≤X,Y≤N,∑Ti=1N≤300000

Output

  For each test case,the output will be only a line.

  Please print “Lying” if you can make sure that Derek is lying,otherwise please print “Not lying”.

Sample Input

2
3 1 3
AAA
ABC
5 5 0
ABCBC
ACBCB

Sample Output

Not lying
Lying

思路:

  思维题,还是没想太明白,大体思路就是先扫一遍如果有相同的就认为他们俩那道题都答对了,然后再扫第二遍如果他们俩不一样就可以随机认为其中有一个人对有一个人错,在这里的处理就是如果x不为零的话就x--,如果y不为零的话就y--,最后如果两个人的分数都为零的话就说明没有说谎。

实现:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 200;
#define mod 100000007
int main() {
    int T;
    string a,b;
    cin >> T;
    while (T--) {
        int n,x,y;
        cin >> n >> x >> y >> a >> b;
        int cnt=0;
        for(int i=0;i<n;i++)
            if (a[i]==b[I]&&x&&y) x--,y--;
        for(int i=0;i<n;i++)
            if (a[i]!=b[i]) if (x) x--;else if (y) y--;
        if(x||y) cout<<"Lying"<<endl;
        else cout<<"Not lying"<<endl;
    }
    return 0;
}

优化:

  这是别人优化版的代码,没有看懂是什么意思,跑了50MS,也先贴一下。

#include <bits/stdc++.h>
using namespace std;
#define maxn 80007
int main() {
    ios_base::sync_with_stdio(false);
    cin.tie(nullptr);
    int t,n,x,y;
    string a,b;
    cin >> t;
    while(t--!=0) {
        cin >> n >> x >> y >> a >> b;
        if(x<y) swap(x,y);
        int cnt{};
        for(int i=0 ; i<n ; i++) if(a[i] == b[i]) cnt++;
        if((x+y-cnt<=n&&y>=cnt)||(cnt>=y&&n-cnt>=x-y)) cout << "Not lying\n";
        else cout << "Lying\n";
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值