POJ-1836 Alignment

21 篇文章 0 订阅
1 篇文章 0 订阅

Alignment
原题链接
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 17800 Accepted: 5859
Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , … , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line’s extremity (left or right). A soldier see an extremity if there isn’t any soldiers with a higher or equal height than his height between him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.
Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:
2 <= n <= 1000
the height are floating numbers from the interval [0.5, 2.5]
Output

The only line of output will contain the number of the soldiers who have to get out of the line.
Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2
Sample Output

4
Source

Romania OI 2002

对准
原题链接
时间限制: 1000MS 内存限制: 30000K
提交总数: 17800 接受: 5859
描述

令到原队列的最少士兵出列后,使得新队列任意一个士兵都能看到左边或者右边的无穷远处。

编写一个程序,了解每个士兵的身高,确定必须脱离队员的最低人数。
输入

在输入的第一行写入士兵的数量n。在第二行写入一系列n个浮点数,最多5位精度,并用空格字符分隔。这条线的第k个数字表示具有代码k(1 <= k <= n)的士兵的身高。

有一些限制:
2 <= n <= 1000
高度是从区间[0.5,2.5]
输出

唯一的产出线将包含必须脱离队伍的士兵人数。
示例输入

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2
示例输出

4
资源

罗马尼亚OI 2002

题解
题目大意就是使得队列左右两半(不一定要刚好二分之一)分别为升和降序的时候,队列最少要删去几个人,就和合唱队列那题一样。
思路自然是求一趟最长升和最长降,然后枚举最后可以得到的队列最长长度,n 减去这个数就是答案了。

代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=1005;
int n,ans,fL[maxn],fR[maxn];
double a[maxn];
int main()
{
    scanf("%d",&n);
    for (int i=1;i<=n;i++) scanf("%lf",a+i);
    for (int i=1;i<=n;i++)
     for (int j=i+1;j<=n;j++)
       if (a[j]>a[i]&&fL[j]<fL[i]+1) fL[j]=fL[i]+1;
    for (int i=n;i>=1;i--)
     for (int j=i-1;j>=1;j--)
       if (a[j]>a[i]&&fR[j]<fR[i]+1) fR[j]=fR[i]+1;
    for (int i=1;i<=n;i++)
     for (int j=i+1;j<=n;j++) ans=max(ans,fL[i]+fR[j]+2);
    printf("%d",n-ans);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值