compromise

</pre><p></p><p class="title-middle" style="font-size:16px; font-weight:bold; font-family:Tahoma,Verdana,Arial,sans-serif; text-align:center">Problem D : Compromise</p><p style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px; text-align:center"><a target=_blank target="_blank" href="http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=11&page=show_problem&problem=472" style="text-decoration:none">From:UVA, 531</a></p><p style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px"></p><center style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px"><span style="color:green">Time Limit: </span>3000 MS      <span style="color:blue">Special Judge</span></center><hr class="hr-dotted" style="height:1px; border-style:dotted none none; border-top-color:rgb(0,136,238); font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px" /><p style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px">In a few months the European Currency Union will become a reality. However, to join the club, the Maastricht criteria must be fulfilled, and this is not a trivial task for the countries (maybe except for Luxembourg). To enforce that Germany will fulfill the criteria, our government has so many wonderful options (raise taxes, sell stocks, revalue the gold reserves,...) that it is really hard to choose what to do.</p><p style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px"></p><p style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px">Therefore the German government requires a program for the following task:</p><p style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px"></p><p style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px">Two politicians each enter their proposal of what to do. The computer then outputs the longest common subsequence of words that occurs in both proposals. As you can see, this is a totally fair compromise (after all, a common sequence of words is something what both people have in mind).</p><p style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px"></p><p style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px">Your country needs this program, so your job is to write it for us.</p><p style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px"></p><h2 style="font-family:Tahoma,Verdana,Arial,sans-serif"><span style="color:#0070e8">input</span></h2><span style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px">The input file will contain several test cases.</span><p style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px">Each test case consists of two texts. Each text is given as a sequence of lower-case words, separated by whitespace, but with no punctuation. Words will be less than 30 characters long. Both texts will contain less than 100 words and will be terminated by a line containing a single '<tt>#</tt>'.</p><p style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px">Input is terminated by end of file.</p><p style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px"></p><h2 style="font-family:Tahoma,Verdana,Arial,sans-serif"><span style="color:#0070e8">output</span></h2><span style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px">For each test case, print the longest common subsequence of words occuring in the two texts. If there is more than one such sequence, any one is acceptable. Separate the words by one blank. After the last word, output a newline character.</span><p style="font-family:Tahoma,Verdana,Arial,sans-serif; font-size:12px"></p><h2 style="font-family:Tahoma,Verdana,Arial,sans-serif"><span style="color:#0070e8">sample input</span></h2><pre style="font-size:12px">die einkommen der landwirte
sind fuer die abgeordneten ein buch mit sieben siegeln
um dem abzuhelfen
muessen dringend alle subventionsgesetze verbessert werden
#
die steuern auf vermoegen und einkommen
sollten nach meinung der abgeordneten
nachdruecklich erhoben werden
dazu muessen die kontrollbefugnisse der finanzbehoerden
dringend verbessert werden
#

Sample output

die einkommen der abgeordneten muessen dringend verbessert werden



本题的题意为输出两个单词序列的最长公共子序列,因此需要先求出最长公共子序列的长度,然后再递归输出,如果在计算的同时进行输出,因为最终的结果未知,所以很可能输出的序列并非是最长公共子序列,因此要求出公共子序列后再回溯,记录路径,进行输出。 设有2组序列a={x1,x2,..xn},b={y1,y2,...ym};我们从最后一个元素开始考虑,如果xn=ym,那么他一定在最长公共子序列中,那么输出;如果xn!=ym,由lcs=max(lcs({x1,...xn-1},{y1,....ym}),lcs({x1....xn},{y1...ym-1})),知最长公共子序列的下一步的查找范围。

#include<iostream>
#include<string>
#include<sstream>
#include<vector>
#define maxn 110
using namespace std;
vector<string>ve,se,de;
int dp[maxn][maxn];
void printlcs(int i,int j){
    if(i==0||j==0) return;
    if(ve[i-1]==se[j-1]){
        printlcs(i-1,j-1);
        de.push_back(ve[i-1]);
    }
    else if(dp[i-1][j]>dp[i][j-1]){
        printlcs(i-1,j);
    }
    else{
        printlcs(i,j-1);
    }
}
int main(){
    string st,str;
        while(getline(cin,st)){
        if(st=="#"){
                while(getline(cin,str)){
                    if(str=="#") break;
                    stringstream ss(str);
                    while(ss>>st){
                        se.push_back(st);
                    }
                }
                vector<string>::iterator it=ve.begin();
                vector<string>::iterator is=se.begin();
                string sm=".";
                ve.insert(it,sm);
                se.insert(is,sm);
                for(int i=1;i<ve.size();i++){
                    for(int j=1;j<se.size();j++){
                        dp[i][j]=dp[i-1][j];
                        if(dp[i][j-1]>dp[i][j]) dp[i][j]=dp[i][j-1];
                        if(ve[i]==se[j]&&(dp[i-1][j-1]+1)>dp[i][j]){
                            dp[i][j]=dp[i-1][j-1]+1;
                        }
                    }
                }
                ve.erase(it);
                se.erase(is);
                printlcs(ve.size(),se.size());
                for(int i=0;i<de.size();i++){
                    if(i)cout<<" ";
                    cout<<de[i];
                }
                cout<<endl;
                ve.clear();
                se.clear();
                de.clear();
            }
            stringstream ss(st);
            while(ss>>str){
                ve.push_back(str);
            }

        }

return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值