PAT--1061. Dating

Sherlock Holmes received a note with some strange strings: “Let’s date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm”. It took him only a minute to figure out that those strange strings are actually referring to the coded time “Thursday 14:04” – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter ‘D’, representing the 4th day in a week; the second common character is the 5th capital letter ‘E’, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is ‘s’ at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format “DAY HH:MM”, where “DAY” is a 3-character abbreviation for the days in a week – that is, “MON” for Monday, “TUE” for Tuesday, “WED” for Wednesday, “THU” for Thursday, “FRI” for Friday, “SAT” for Saturday, and “SUN” for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm

Sample Output:

THU 14:04

题解

  • 前两个字符串中,第一个在下标相同位置处相同的大写字母,范围是A~G,作为星期;第二个在下标相同位置处相同的字符,范围0~9和A~N,作为小时。

  • 后两个字符串中,第一个在下标相同位置处相同的字母,其下标作为分钟。

  • 注意输出格式。
#include <bits/stdc++.h>
using namespace std;

string s1, s2, s3, s4;
string day[] = {"MON", "TUE", "WED", "THU", "FRI", "SAT", "SUN"};

int main(){
    cin >> s1 >> s2 >> s3 >> s4;

    int day_pos = 0, hour = 0, minute = 0;
    int flag = 0;
    for(int i = 0; i < s1.length() && i < s2.length(); ++i){
        if(s1[i] == s2[i]){
            if(!flag && 'A' <= s1[i] && s1[i] <= 'G'){
                day_pos = s1[i] - 'A';
                flag = 1;
            }else if(flag){
                if(isdigit(s1[i])) { hour = s1[i] - '0'; break; }
                else if('A' <= s1[i] && s1[i] <= 'N'){
                    hour = s1[i] - 'A' + 10;
                    break;
                }
            }
        }

    }

    for(int i = 0; i < s3.length() && i < s4.length();  ++i){
        if(isalpha(s3[i]) && s3[i] == s4[i]){
            minute = i;
            break;
        }
    }

    printf("%s %02d:%02d\n", day[day_pos].c_str(), hour, minute);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值