1071. Speech Patterns (25)

题目如下:

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return '\n'. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:
Can1: "Can a can can a can?  It can!"
Sample Output:
can 5



题目要求从一个自然段(一行句子,包含特殊字符)中找出出现频率最高的单词,注意这里的单词定义,连续的字符数字序列,数字也是合法的。要做出此题目,可以使用getline读取一行句子,然后遍历过程中用stringstream接收字符,在处理完一个单词后输出,再用map记录单词的出现频率。

①连带空格读取一行,使用getline(cin,str);

②分割单词,对读到的自然段para,从前到后遍历,使用一个stringstream记录读到的字符串,一旦读到非法字符,就把当前stringstream的内容都输出到一个字符串word,判断word长度是否大于0,大于0则说明是一个单词,用map记录当前单词的出现次数,并按照题目要求比较,特别注意单词只出现一次的情况

③注意如果读到的自然段para只有一个单词,没有除换行符以外的分隔符,需要特殊处理,这是因为getline读不到\n。

注意点:

①stringstream输出字符串使用ss.str()。

②清空stringstream不要用ss.clear,应该用ss.str("")。

代码如下:

#include <iostream>
#include <map>
#include <stdio.h>
#include <sstream>
#include <string>
#include <algorithm>

// stringstream 清空使用 ss.str("")
// transform

using namespace std;

int main()
{
    map<string,int> words;
    string para;
    getline(cin,para);
    stringstream ss;
    string word;
    string maxWord = "";
    int maxCnt = -1;

    bool singleFlag = true;
    string single;

    for(int i = 0; i < para.length(); i++)
    {
        char c = para[i];
        if(isalnum(c)){
            ss << c;
            if(singleFlag){
                single = ss.str();
            }

        }else{
            singleFlag = false;
            word = ss.str();
            if(word.length() > 0){
                transform(word.begin(), word.end(), word.begin(), ::tolower);

                ss.str("");
                if(words.find(word) == words.end()){
                    words[word] = 1;
                    int cnt = 1;
                    if(cnt > maxCnt){
                        maxCnt = cnt;
                        maxWord = word;
                    }else if(cnt == maxCnt){
                        if(word < maxWord){
                            maxWord = word;
                        }
                    }
                }else{
                    words[word]++;
                    int cnt = words[word];
                    if(cnt > maxCnt){
                        maxCnt = cnt;
                        maxWord = word;
                    }else if(cnt == maxCnt){
                        if(word < maxWord){
                            maxWord = word;
                        }
                    }
                }
            }
        }
    }

    if(singleFlag){
        printf("%s 1\n",single.c_str(),maxCnt);
    }else{
        printf("%s %d\n",maxWord.c_str(),maxCnt);
    }


    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值