uva455 周期串 第三章习题4

A character string is said to have period k if it can be formed by concatenating one or more repetitions
of another string of length k. For example, the string ”abcabcabcabc” has period 3, since it is formed
by 4 repetitions of the string ”abc”. It also has periods 6 (two repetitions of ”abcabc”) and 12 (one
repetition of ”abcabcabcabc”).
Write a program to read a character string and determine its smallest period.
Input
The first line oif the input file will contain a single integer N indicating how many test case that your
program will test followed by a blank line. Each test case will contain a single character string of up
to 80 non-blank characters. Two consecutive input will separated by a blank line.
Output
An integer denoting the smallest period of the input string for each input. Two consecutive output are
separated by a blank line.

Sample Input
1
HoHoHo

Sample Output
2

ps:这道题就是找一个串的最小周期串的长度 重点想法就是 先找出能被len整除的长度数i,例 若长度为10 ,则找出i=2,5,10这三个数,开始i=2 判断 if(s[j]!=s[j%i]) 则i等于下一个 即5 。。符合就输出

#include <cstring>
#include <cstdio>
#include <cctype>
#include <iostream>
#include <cstdlib>
#include <vector>
using namespace std;

int main()
{
    char s[88];
    int n,j,len;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",s);
        len=strlen(s);
        for(int i=1;i<=len;i++)
        {
            if(len%i==0)
            {
                j=i;
                for(;j<len;j++)
                {
                    if(s[j]!=s[j%i])
                        break;
                }
                if(j==len)
                    {
                        printf("%d\n",i);
                        break;
                    }
            }
        }
        if(n) printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值