Conscription 3723(最小生成树变形)

32 篇文章 1 订阅
31 篇文章 0 订阅
Conscription
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9330 Accepted: 3296

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223
//克鲁斯特拉算法 
/*题意::
		国王召N个男,M个女当兵,召每个人的费用为10000元,但如果两个人有联系,其亲密度为D,那么
		召另外一个人的费用为10000-D,问国王最少花费多少钱 
*/
//技巧,将男女编号连起来,也就是将女的编号连到男的编号后,
//如男  0 1 2 3 4    女  0 1 2 3 4
//连起来为0 1 2 3 4 (0+n)=5 (1+n)=6 (2+n)=7 (3+n)=8 (4+n)=9
//这样简单,方便操作  
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[50010];
int sum,n,m,t;
struct zz
{
	int x,y,l;
}q[50010];
int cmp(zz x,zz y)
{
	return x.l>y.l;
}
void init()
{
	int i;
	for(i=0;i<n*2;i++)	
	a[i]=i;
}
/*int find(int x)	//这种超时 
{
	while(x!=a[x])
		x=a[x];
	return x;
}*/
int find (int x)
{
	int r=x;
	while(r!=a[r])
		r=a[r];
	int i=x,j;
	while(i!=r)
	{
		j=a[i];
		a[i]=r;
		i=j;
	}
	return r;
}
int marge(int x,int y,int z)
{
	int fx,fy;
	fx=find(x);fy=find(y);
	if(fx!=fy)
	{
		sum-=z;
		a[fx]=fy;
	}
}
int main(){
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int i,x,y,l;
		scanf("%d%d%d",&n,&m,&t);
		init();
		for(i=0;i<t;i++)
		{
			scanf("%d%d%d",&x,&y,&l);
			q[i].x=x;
			q[i].y=y+n;		//技巧,将男女编号划分开 
			q[i].l=l;
		}
		sort(q,q+t,cmp);
		sum=(n+m)*10000;
		for(i=0;i<t;i++)
		{
			marge(q[i].x,q[i].y,q[i].l);
		}
		printf("%d\n",sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值