hdoj Junk-Mail Filter 2473 (并查集的删点) 好题

211 篇文章 1 订阅
32 篇文章 1 订阅

Junk-Mail Filter

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7727    Accepted Submission(s): 2439


Problem Description
Recognizing junk mails is a tough task. The method used here consists of two steps:
1) Extract the common characteristics from the incoming email.
2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so
relationships (other than the one between X and Y) need to be created if they are not present at the moment.

b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.
Please help us keep track of any necessary information to solve our problem.

Input
There are multiple test cases in the input file.
Each test case starts with two integers, N and M (1 ≤ N ≤ 10 5 , 1 ≤ M ≤ 10 6), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.
Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.

Output
For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.

Sample Input
  
  
5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0

Sample Output
  
  
Case #1: 3 Case #2: 2
//题意:
有n 张邮票,编号为(0-->n-1)。现在有两种操作
1、 M x y:表示将x邮票与y邮票合并为一张。
2、 S x :表示将x邮票单独提取出来作为一张。
问最终有几张邮票。
 
//与nyoj上的 “合纵连横”题一样。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1000100];
int b[1000100];
bool c[1000100];
int n,m;
/*int find(int x)//用递归找根节点 
{
	return a[x]==x?a[x]:a[x]=find(a[x]);
}*/
int find(int x)
{
	int t;
	int y=x;
	while(x!=a[x])
		x=a[x];
	while(y!=x)
	{
		t=a[y];
		a[y]=x;
		y=t;
	}
	return x;
}
int marge(int x,int y)
{
	int fx,fy;
	fx=find(x);fy=find(y);
	if(fx!=fy)
		a[fx]=fy;
}
int main()
{
	int T=1;
	int i,j,k,x,y;
	char ch;
	while(scanf("%d%d",&n,&m),n|m)
	{
		k=n;		
		for(i=0;i<n;i++)
		{
			a[i]=i;
			b[i]=i;
		}
		while(m--)
		{
			getchar();
			scanf("%c",&ch);
			if(ch=='M')
			{
				scanf("%d%d",&x,&y);
				marge(b[x],b[y]);
			}
			else
			{
				scanf("%d",&x);
				b[x]=k;
				a[k]=k;
				k++;
			}
		}
		int cnt=0;
		memset(c,false,sizeof(c));
		for(i=0;i<n;i++)
		{
			int tmp=find(b[i]);//tmp表示根节点 
			if(!c[tmp])
			{
				cnt++;//记录有几个根节点 
				c[tmp]=true;
			}
		}
		printf("Case #%d: %d\n",T++,cnt);
	}
	return 0;
}

//下面的用到了set函数,省去了c[]数组以为会省时,没想到还多了100Ms。。。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<set>
using namespace std;
int a[1000010];
int b[1000010];
int find(int x)
{
	return a[x]==x?a[x]:a[x]=find(a[x]);
}
int marge(int x,int y)
{
	int fx,fy;
	fx=find(x);
	fy=find(y);
	if(fx!=fy)
		a[fx]=fy;
}
set<int>s;
int main()
{
	int n,m;
	int i,j,k;
	int x,y;
	int T=1;
	while(scanf("%d%d",&n,&m),n|m)
	{
		k=n;
		for(i=0;i<1000000;i++)
			a[i]=i;
		for(i=0;i<n;i++)
			b[i]=i;
		char ch;
		while(m--)
		{
			getchar();
			scanf("%c",&ch);
			if(ch=='M')
			{
				scanf("%d%d",&x,&y);
				marge(b[x],b[y]);
			}
			else
			{
				scanf("%d",&x);
				b[x]=k;
				k++;
			}
		}
		s.clear();
		for(i=0;i<n;i++)
			s.insert(find(b[i]));
		printf("Case #%d: %d\n",T++,s.size());
	}
	return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值