1205: C hicken and rabbit s (简单数学题)

1205: C hicken and rabbit s

时间限制: 1 Sec   内存限制: 32 MB
提交: 53   解决: 36
[ 提交][ 状态][ 讨论版]

题目描述

Chicken and rabbits are in a same cage. As we all know, chicken has two legs but rabbit has four. Now
we know the number of legs in the cage is A, please tell me how many animals may in the cage at least
and at most.

输入

The first line of the input contains the number of test cases in the file. Each test case that follows
consists of one lines. each case contains only one integer numbers A specifying the total legs in the
cage .

输出

For each test case, print a line contains the answer

样例输入

2
3
20

样例输出

0 0
5 10
 
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define MIN(x,y)(x<y?x:y)
#define MAX(x,y)(x>y?x:y)
using namespace std;
int main(){
	int t,n,min,max;
	scanf("%d",&t);
	while(t--)
	{
		min=0;max=0;
		scanf("%d",&n);
		if(n&1)
			printf("0 0\n");
		else
		{
			max=n/2;
			if(n%4==0)
				min=n/4;
			else
				min=(n-2)/4+1;
			printf("%d %d\n",min,max);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值