poj River Hopscotch 3258 (二分)好题

99 篇文章 0 订阅
River Hopscotch
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9868 Accepted: 4215

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Difrom the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers:   L,   N, and   M  
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing   M  rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4
//题意:
一条长为L的河中有n个石头,现在要去掉m个石头,因为去掉m个石头会有很多很多种情况(记住会有很多种情况),并且组成的“每种情况”都会有一个最小的间距dis(也就是相邻两块石头之间的最小间距为dis),现在问在这么多种情况中最大的间距为多少(也就是求MAX(dis))。
每种情况输入三个数L,n,m。
接下来输入n个数,表示n个石头所在的位置(相对于起点0)。
输出MAX(dis)。
//思路:
题意理解了就比较简单了,利用二分查找,具体看代码。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define ll __int64
#define N 50010
using namespace std;
ll a[N];
ll L,n,m;
bool find(ll x)
{
	int num=0;
	int k=0;
	for(int i=1;i<=n+1;i++)
	{
		if(x>=a[i]-a[k])//这块是关键,一直遍历,找到两石块间距离(a[i]-a[k])<=x的个数 
			num++;
		else
			k=i;
	}
	if(num>m)//如果个数(num)比m大,表示x找的值太大了,那么距离得缩小,否则距离得增大。 
		return true;
	return false;
}
int main()
{
	while(scanf("%d%d%d",&L,&n,&m)!=EOF)
	{
		for(int i=1;i<=n;i++)
			scanf("%I64d",&a[i]);
		a[0]=0;a[n+1]=L;
		sort(a+1,a+n+1);
		ll l=0,r=L,mid;
		while(l<=r)
		{
			mid=(l+r)/2;
			if(find(mid))//x找的值太大了,距离得缩小
				r=mid-1;
			else         //x找的值太小了,距离得增大
				l=mid+1;
		}
		printf("%I64d\n",l);
	}
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值