解决dpkg: ../../src/packages.c:227: process_queue: Assertion `dependtry <= 4' failed

诡异的这个问题,只要安装npm就会遇到(sudo apt-get install npm):

dpkg: ../../src/packages.c:227: process_queue: Assertion `dependtry <= 4' failed.
E: Sub-process /usr/bin/dpkg exited unexpectedly

网上搜的方法都不能解决,导致git,npm都没法安装,但安装nodejs却没事。

后来发现可能是dpkg的问题,重新安装dpkg就好了:

$ sudo apt-get install dpkg



阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/ybdesire/article/details/49895287
文章标签: linux
个人分类: linux
上一篇[多浏览器兼容]IE浏览器HTML条件注释
下一篇JS获取文本在HTML中的真实长度
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭