hdu 1498 50 years, 50 colors( 二分图最大匹配)

On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons". 

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons. 

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times. 


 

Input

There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0. 
 

Output

For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1". 
 

Sample Input

    
    
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0
 

Sample Output

    
    
-1 1 2 1 2 3 4 5 -1
 







#include<stdio.h>
#include<string.h>
#include<stdlib.h>

#define N 101

int map[N][N],flag[N];
int pp[N];
int a[N][N];
int b[N];
int n,m;
int sum;

int find(int x)
{
    int i;
    for(i=1;i<=n;i++)
    {
        if(map[x][i] == 1 && flag[i] == 0)
        {
            flag[i] = 1;
            if(pp[i] == -1 || find(pp[i]))
            {
                pp[i] = x;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    int i,j,k,e,r;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n == 0 && m == 0)
        {
            break;
        }
        int count = 0;
        memset(map,0,sizeof(map));
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        e = 0;
        for(i=1;i<=50;i++)
        {
            sum = 0;
            memset(pp,-1,sizeof(pp));
            for(j=1;j<=n;j++)
            {
                for(r=1;r<=n;r++)
                {
                    if(a[j][r] == i)
                    {
                        map[j][r] = 1;
                    }
                    else
                    {
                        map[j][r] = 0;
                    }
                }
            }
            for(j=1;j<=n;j++)
            {
                memset(flag,0,sizeof(flag));
                sum += find(j);
            }
            if(sum>m)
            {
                b[e++] = i;
                count = 1;
            }
        }
        if(count == 0)
        {
            printf("-1\n");
        }
        else
        {
            for(i=0;i<e;i++)
            {
                if(i == 0)
                {
                    printf("%d",b[i]);
                }
                else
                {
                    printf(" %d",b[i]);
                }
            }
            printf("\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值