UVA Graph Coloring(DFS+回溯)

 Graph Coloring 

You are to write a program that tries to find an optimal coloring for a given graph. Colors are applied to the nodes of the graph and the only available colors are black and white. The coloring of the graph is called optimal if a maximum of nodes is black. The coloring is restricted by the rule that no two connected nodes may be black.

 figure22
Figure: An optimal graph with three black nodes

Input and Output

The graph is given as a set of nodes denoted by numbers tex2html_wrap_inline33 , tex2html_wrap_inline35 , and a set of undirected edges denoted by pairs of node numbers tex2html_wrap_inline37 , tex2html_wrap_inline39 . The input file contains m graphs. The number m is given on the first line. The first line of each graph contains n and k, the number of nodes and the number of edges, respectively. The following k lines contain the edges given by a pair of node numbers, which are separated by a space.

The output should consists of 2m lines, two lines for each graph found in the input file. The first line of should contain the maximum number of nodes that can be colored black in the graph. The second line should contain one possible optimal coloring. It is given by the list of black nodes, separated by a blank.

Sample Input

1
6 8
1 2
1 3
2 4
2 5
3 4
3 6
4 6
5 6

Sample Output

3
1 4 5
 
     
 
     
题意:在满足黑色棋子之间不直接相连的前提下输出最大的黑色棋子的数量。


代码:

      
      
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

int map[101][101];
int v[101];
int n,m;
int maxx;
int a[101],b[101];

bool findx(int ii)
{
    for(int i=1;i<=n;i++)
    {
        if(map[ii][i] == 1 && a[i] == 1)
        {
            return false;
        }
    }
    return true;
}

void DFS(int sum,int p)
{
    if(p == n+1)
    {
        if(sum > maxx)
        {
            maxx = sum;
            for(int i=1;i<=n;i++)
            {
                b[i] = a[i];
            }
        }
        return ;
    }
    if(sum+n-p < maxx)
    {
        return ;
    }
    a[p] = 1;
    if(findx(p))
    {
        DFS(sum+1,p+1);

    }
    a[p] = 0;
    DFS(sum,p+1);

}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        int x,y;
        memset(map,0,sizeof(map));
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&x,&y);
            map[x][y] = 1;
            map[y][x] = 1;
        }
        maxx = 0;
        memset(v,0,sizeof(v));
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        DFS(0,1);
        printf("%d\n",maxx);
        int flag = 0;
        for(int i=1;i<=n;i++)
        {
            if(b[i] == 1 && flag == 0)
            {
                printf("%d",i);
                flag = 1;
            }
            else if(b[i] == 1)
            {
                printf(" %d",i);
            }
        }
        printf("\n");
    }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值