poj 3311 Hie with the Pie(状压 经典TSP)@

该博客讨论了如何解决一个经典的旅行商问题(TSP)变种,即在一个送外卖的人需要将外卖送到多个地点并返回到起点的场景中找到最短路径。博主通过Floyd算法求出最短路径,并使用动态规划(DP)方法优化解决方案,其中DP数组用于记录每个状态到达目标状态的最短时间。博客强调了在处理DP数组时的一些技巧,如初始化和状态转移的细节。
摘要由CSDN通过智能技术生成


Hie with the Pie
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8




题意:一个送外卖的人,要将外卖全部送去所有地点再回到店离,求最短路
首先用floyd求出最短路,然后再进行DP即可
dp[i][j]表示i这个状态下,目标是j的最短路,i是用二进制表示每个地点是否去过 

给定一系列点,求从0点出发,走完其它点,可以重复走,回到0点的最短路程.
假设n==4,那么点为0,1,2,3;
路径可能为0 1 2 3 0
        0 3 2 1 0
        0 3 1 2 0
     。。。。。。。 等等,
其实就是1到n-1的排列组合,每次有n-1中选择,需要算出每种状态的值,找到最小值,我们可以设到达j点,已经经过了s,s表示经过点的集合。
采用顺推的写法 dp[s | (1 <<k) ][k]=min(dp[s][j]+d[j][k],dp[s | (1<<k)][k]);

这题处理时需要一些技巧,因为开始 从  Pizzeria    出发所以将DP数组初始化为-1,起点为0,在可以达到的状态更新未达到的状态,因为要求终点也为 Pizzeria   所以开二维数组标记当前所在更新点,,,在可以达到的状态跟新不同的当前点,有点像最短路,,,需要理解其中含义,,。。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int N = 13;
int a[N][N], dp[1<<N][N];
const int inf = 0x3f3f3f3f;


int main()
{
    int n;
    while(scanf("%d", &n),n)
    {
        for(int i=0;i<=n;i++)
        {
            for(int j=0;j<=n;j++)
            {
                scanf("%d", &a[i][j]);
            }
        }
        for(int k=0;k<=n;k++)
        {
            for(int i=0;i<=n;i++)
            {
                for(int j=0;j<=n;j++)
                {
                    if(a[i][j]>a[i][k]+a[k][j])
                        a[i][j]=a[i][k]+a[k][j];
                }
            }
        }
        n++;
        memset(dp,-1,sizeof(dp));
        dp[1][0]=0;
        for(int i=1;i<(1<<(n));i++)
        {
            for(int j=0;j<=n;j++)
            {
                if(!(i&(1<<j))||dp[i][j]==-1)
                    continue;
                for(int k=0;k<=n;k++)
                {
                    if(j==k)
                        continue;
                    int state=i|(1<<k);
                    if(dp[state][k]==-1||dp[state][k]>dp[i][j]+a[j][k])
                          dp[state][k]=dp[i][j]+a[j][k];
                }
            }
        }
        printf("%d\n",dp[(1<<(n))-1][0]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值