[poj2478]Farey Sequence(筛法求欧拉函数)

Farey Sequence

Time Limit: 1000MS      Memory Limit: 65536K
Total Submissions: 16106        Accepted: 6403
Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.
Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.
Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 
Sample Input

2
3
4
5
0
Sample Output

1
3
5
9
Source

POJ Contest,Author:Mathematica@ZSU

给定一个数n,求在[1,n]这个范围内两两互质的组合数。则问题可以转化为欧拉函数问题了。

欧拉函数性质(引用自http://www.2cto.com/kf/201406/309430.html

1.欧拉函数是求小于n且和n互质(包括1)的正整数的个数。记为φ(n)。
2.欧拉定理:若a与n互质,那么有a^φ(n) ≡ 1(mod n),经常用于求幂的模。
3.若p是一个质数,那么φ(p) = p-1,注意φ(1) = 1。
4.若m与n互质,那么φ(nm) = φ(n) * φ(m)。
若n = p^k且p为质数,那么φ(n) = p^k - p^(k-1) = p^(k-1) * (p-1)。
5.当n为奇数时,有φ(2*n) = φ(n)。
6.基于素数筛的求欧拉函数的重要依据:
设a是n的质因数,若(N%a == 0 && (N/a)%a == 0) 则 φ(N) = φ(N/a)*a; 若(N%a == 0 && (N/a)%a != 0) 则φ(N) = φ(N/a)*(a-1)。
#include<iostream>
#include<cstdio>
using namespace std;

const int N = 1000010;

bool isnot[N];
int pri[N], phi[N], ptot;
long long sum[N];

void init( int n ) {
    isnot[1] = true;
    phi[1] = 1;
    for( int i = 2; i <= n; i++ ) {
        if( !isnot[i] ) {
            pri[ptot++] = i;
            phi[i] = i - 1;
        } 
        for( int t = 0; t < ptot; t++ ){
            int j = pri[t] * i;
            if( j > n ) break;
            isnot[j] = true;
            if( i % pri[t] ) {
                phi[j] = phi[pri[t]] * phi[i];
            } else {
                phi[j] = pri[t] * phi[i];
                break;
            }
        }
    }
    for( int i = 2; i <= n; i++ )
        sum[i] = sum[i-1] + phi[i];
}

int main() {
    init(1000000);
    int n;
    while( scanf("%d",&n) == 1 && n ) {
        cout << sum[n] << endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值