HDOJ 题目1867A + B for you again(KMP)

A + B for you again

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4407    Accepted Submission(s): 1132


Problem Description
Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.
 

Input
For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.
 

Output
Print the ultimate string by the book.
 

Sample Input
  
  
asdf sdfg asdf ghjk
 

Sample Output
  
  
asdfg asdfghjk
 

Author
Wang Ye
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1866  1277  1358  1869  1868 
有重复的就覆盖掉 然后输出。不过这个得比较字符串str1 str2还得再比较str2 str1 
ac代码
#include<stdio.h>
#include<string.h>
int next[100010];
void getnext(char *s)
{
	int len,j=0,k=-1;
	len=strlen(s);
	next[0]=-1;
	while(j<len)
	{
		if(k==-1||s[k]==s[j])
		{
			j++;
			k++;
			next[j]=k;
			/*if(s[j]!=s[k])
				next[j]=k;
			else
				next[j]=next[k];*/
		}
		else
			k=next[k];
	}
}
int kmp(char *s1,char *s2)
{
	int i=0,j=0,k;
	int len1=strlen(s1),len2=strlen(s2);
	getnext(s2);
	while(i<len1&&j<len2)
	{
		if(j==-1||s1[i]==s2[j])
		{
			i++;
			j++;
		}
		else
			j=next[j];
	}
	if(i==len1)
		return j;
	return 0;
}
int main()
{
	char s1[100010],s2[100010];
	while(scanf("%s%s",s1,s2)!=EOF)
	{
		int x=kmp(s1,s2);
		int y=kmp(s2,s1);
		if(x==y)
		{
			if(strcmp(s1,s2)>0)
			{
				printf("%s",s2);
				printf("%s\n",s1+y);
			}
			else
			{
				printf("%s",s1);
				printf("%s\n",s2+x);
			}
		}
		else
			if(x>y)
			{
				printf("%s",s1);
				printf("%s\n",s2+x);
			}
			else
			{
				printf("%s",s2);
				printf("%s\n",s1+y);
			}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值