HDOJ 题目4268 Alice and Bob(multiset,贪心)

22 篇文章 0 订阅

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2984    Accepted Submission(s): 970


Problem Description
Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.
 

Input
The first line of the input is a number T (T <= 40) which means the number of test cases.
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's.
 

Output
For each test case, output an answer using one line which contains just one number.
 

Sample Input
  
  
2 2 1 2 3 4 2 3 4 5 3 2 3 5 7 6 8 4 1 2 5 3 4
 

Sample Output
  
  
1 2
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   4276  4274  4272  4277  4267 
 ac代码
#include<stdio.h>
#include<string.h>
#include<set>
#include<iostream>
#include<algorithm>
using namespace std;
struct s
{
	int x,y;
}b[100100],a[100100];
bool cmp(s a,s b)
{
	if(a.x==b.x)
		return a.y<b.y;
	return a.x<b.x;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,i;
		scanf("%d",&n);
		multiset<int>m;
		multiset<int>::iterator it;
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&a[i].x,&a[i].y);
		}
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&b[i].x,&b[i].y);
		}
		sort(a,a+n,cmp);
		sort(b,b+n,cmp);
		int j=0;
		int ans=0;
		for(i=0;i<n;i++)
		{
			while(j<n&&a[i].x>=b[j].x)
			{
				m.insert(b[j].y);
				j++;
			}
			if(m.empty())
				continue;
			it=m.upper_bound(a[i].y);
			if(it!=m.begin())
			{
				it--;
				ans++;
				m.erase(it);
			}
		}
		printf("%d\n",ans);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值