hdu5240 Exam

Exam

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 756 Accepted Submission(s): 384


Problem Description
As this term is going to end, DRD needs to prepare for his final exams.

DRD has n exams. They are all hard, but their difficulties are different. DRD will spend at least ri hours on the i -th course before its exam starts, or he will fail it. The i -th course's exam will take place ei hours later from now, and it will last for li hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time.

So he wonder whether he can pass all of his courses.

No two exams will collide.

Input
First line: an positive integer T20 indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer n105 , and n lines follow. In each of these lines, there are 3 integers ri,ei,li , where 0ri,ei,li109 .


Output
For each test case: output ''Case #x: ans'' (without quotes), where x is the number of test cases, and ans is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes).


Sample Input
  
  
2 3 3 2 2 5 100 2 7 1000 2 3 3 10 2 5 100 2 7 1000 2

Sample Output
  
  
Case #1: NO Case #2: YES

Source

题意:DRD有n们课程,每次输入三个数分别表示该们课需要复习的时间、考试开始的时间、考试执行的时间。
分析:刚一看题就觉得是贪心,立马就写了,然而WA了三次,着实不解哪里有错,然后看到一片博客,我就呵呵了,就是一大水题,然而题意没说清楚;题目并没有说可以多门课程一起复习,然而这么写却是可以过的。我也真是无力吐槽了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

struct node
{
    ll r,e,l;
}s[100005];

ll cmp(node a, node b)
{
    return a.e<b.e;
}

int main ()
{
    int T,n,ii=1;
    scanf ("%d",&T);
    while (T--)
    {
        scanf ("%d",&n);
        bool flag=false;
        for (int i=0; i<n; i++)
        {
            scanf ("%lld%lld%lld",&s[i].r,&s[i].e,&s[i].l);
            if (s[i].r > s[i].e)//直接判断是否有需要复习时间在考试开始时间之后就行
            {
                flag = true;
            }
        }
        /*sort(s, s+n, cmp);//这是我之前的WA代码
        ll sum=0;

        for (int i=0; i<n; i++)
        {
            if (s[i].e<sum+s[i].r || s[i].r>s[i].e)
            {
                flag = true;
                break;
            }
            else sum += (s[i].r+s[i].e+s[i].l);
        }*/
        printf ("Case #%d: ",ii++);
        if (flag)
            printf ("NO\n");
        else
            printf ("YES\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值