【2017广西邀请赛】hdu 6188 Duizi and Shunzi 贪心

Problem Description
Nike likes playing cards and makes a problem of it.

Now give you n integers,  ai(1in)

We define two identical numbers (eg:  2,2 ) a Duizi,
and three consecutive positive integers (eg:  2,3,4 ) a Shunzi.

Now you want to use these integers to form Shunzi and Duizi as many as possible.

Let s be the total number of the Shunzi and the Duizi you formed.

Try to calculate  max(s) .

Each number can be used only once.
 

Input
The input contains several test cases.

For each test case, the first line contains one integer n( 1n106 ). 
Then the next line contains n space-separated integers  ai  ( 1ain )
 

Output
For each test case, output the answer in a line.
 

Sample Input
  
  
7 1 2 3 4 5 6 7 9 1 1 1 2 2 2 3 3 3 6 2 2 3 3 3 3 6 1 2 3 3 4 5
 

Sample Output
  
  
2 4 3 2
Hint
Case 1(1,2,3)(4,5,6) Case 2(1,2,3)(1,1)(2,2)(3,3) Case 3(2,2)(3,3)(3,3) Case 4(1,2,3)(3,4,5)
 

题意:

给你一串数字,求能得到的顺子数和对子数的最大和。


思路:

排序贪心取,能取就直接取。

//
//  main.cpp
//  1007
//
//  Created by zc on 2017/9/6.
//  Copyright © 2017年 zc. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define ll long long
using namespace std;
const int N=1100000;
int n,a[N],b[N];

int main(int argc, const char * argv[]) {
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)    scanf("%d",&a[i]);
        sort(a,a+n);
        int m=0,ans=0;
        for(int i=0;i<n;i++)
        {
            if(m>0&&b[m]==a[i]) ans++,m--;
            else if(m>1&&b[m]==a[i]-1&&b[m-1]==a[i]-2)   ans++,m-=2;
            else b[++m]=a[i];
        }
        printf("%d\n",ans);
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值