B - Cure (2016 ACM/ICPC Asia Regional Qingdao Online -Cure)

Cure

Given an integer nn, we only want to know the sum of 1/k21/k2 where kk from 11 to nn.

Input

There are multiple cases. 
For each test case, there is a single line, containing a single positive integer nn. 
The input file is at most 1M. 

Output

The required sum, rounded to the fifth digits after the decimal point.

Sample Input

1
2
4
8
15

Sample Output

1.00000
1.25000
1.42361
1.52742
1.58044

 

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;

double Ta[1000000]; 
int main(){
	char n[1000000];
	Ta[1]=1.0;
	for(int i=2;i<1000000;++i){
		Ta[i]=Ta[i-1]+(1.0/i)*(1.0/i);
	}
	while(~scanf("%s",n)){
		int num=0;
		if
			(strlen(n)>6) printf("1.64493\n");
		else
		{
			for(int i=0;i<strlen(n);i++){
				num=num*10+(n[i]-'0');
			}
			printf("%.5f\n",Ta[num]);
		} 	
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值