【HDU 1297】Children’s Queue

  Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 
Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 
Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 
Sample Input
1
2
3

 
Sample Output
1
2
4

【分析】

公式的推导:

1)m

2)mff

3)mfff

a:安全序列后加ff或者m,结果仍然安全。

b:不安全序列后加ff可使其安全,虽然mf加f也能得到安全序列,但与a情况重复。

故:公式a[n]=a[n-1]+a[n-2]+a[n-4];

另外:还要考虑大数相加的问题:因为:n=1000时输出结果:

12748494904808148294446671041721884239818005733501580815621713101333980596197474

74433619974245291299822523591089179822154130383839594330018972951428262366519975

47955743099808702532134666561848656816661065088789701201682837073071502397487823

19037

【总结】

递推求解分类要全面。

一般假设前n-1个合法,然后找规律。

【参考代码】

/*
ID:smqqlzy
LANG:C
PROB:【HDU 1297】Children’s Queue
*/
#include<stdio.h>
int f[1001][1000];

void add(int sub)
{
    int i;
    for(i=0;i<100;i++)
    {
        f[sub][i]=0;
    }
    for(i=1;i<=f[sub-1][0];i++)
    {
        f[sub][i]+=f[sub-1][i]+f[sub-2][i]+f[sub-4][i];
        f[sub][i+1]=f[sub][i]/10;
        f[sub][i]%=10;
    }
    if(f[sub][f[sub-1][0]+1])
    {
        f[sub][0]=f[sub-1][0]+1;
    }
    else
    {
        f[sub][0]=f[sub-1][0];
    }
}


int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int i;
        for(i=0;i<4;i++)
        {
            f[i][0]=1;
        }
        f[0][1]=1;
        f[1][1]=1;
        f[2][1]=2;
        f[3][1]=4;
        for(i=4;i<=n;i++)
        {
            add(i);
        }
        for(i=f[n][0];i>0;i--)
        {
            printf("%d",f[n][i]);
        }
        printf("\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值