Billboard

题目描述:

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information. 

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard. 

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi. 

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one. 

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university). 

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

输入:

There are multiple cases (no more than 40 cases). 

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements. 

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

输出:

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

样例输入:

3 5 5
2
4
3
3
3

样例输出:

1
2
1
3
-1

大体题意是有一个广告牌,高为h,宽为w,现在有很多广告要往这块广告牌上弄,每块广告高都为1,宽为wi。往这块广告牌上弄的原则就是尽量往上面的位置放,同一行尽量往左放。把[1,h]当做一个区间,利用线段树求解。每当某一行满足条件,就减去它相应的宽度。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn=200010;
int MAX[maxn<<2];
int h,w,n;
void pushup(int rt)
{
    MAX[rt]=max(MAX[rt<<1],MAX[rt<<1|1]);
}
void build(int l,int r,int rt)
{
    if(l==r)//初始化每一行的宽度都为w
    {
        MAX[rt]=w;
        return;
    }
    int m=(l+r)>>1;
    build(l,m,rt<<1);
    build(m+1,r,rt<<1|1);
    pushup(rt);
}
int  Query(int x,int l,int r,int rt)
{
    if(l==r)
    {
        MAX[rt]-=x;
        return l;//注意一定要返回左值
    }
    int m=(l+r)>>1;
    int ans=MAX[rt<<1];//左子区间
    if(ans>=x)//如果左子区间能放下这块广告,那就更新左子区间,否则更新右子区间
        ans=Query(x,l,m,rt<<1);
    else
        ans=Query(x,m+1,r,rt<<1|1);
    pushup(rt);
    return ans;
}
int main()
{
    int x;
    while(scanf("%d%d%d",&h,&w,&n)!=EOF)
    {
        if(h>=n)//因为n快广告最多就占n行,如果h大于n,那超出n的多余的h就没有用,这一步如果没
            h=n;//有会runtime error
        build(1,h,1);
        while(n--)
        {
            scanf("%d",&x);
            if(MAX[1]<x)//如果总区间(最大的那个区间)都不能放开这个x宽度的广告牌,那就说明
                printf("-1\n");//哪里也放不开它了,就输出-1
            else
                printf("%d\n",Query(x,1,h,1));
        }
    }
            return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值